Released on: Thursday, 18 May 2017 08:47
Joomla! 3.7 compatibility. Unfortunately, Joomla! 3.7 was released with severe issues in several of its fundamental core APIs. While this is a series of bugs in Joomla! itself we did our best to work around them in a way which will minimise the probability of our software being affected by similar issues in the future.
Removing the automated update CLI script. This happens for two reasons. First, very few people were using it. Second, and most important, Joomla! broke the session handling which in turn breaks all CLI scripts. The only workaround to that is rewriting the application to NOT use any Joomla! core code that can even remotely touch JSession. Unfortunately, fetching and applying extension updates falls into the category of affected code. While we could write our own installation library for CLI updates this is expressly forbidden by the Joomla! Extension Directory (JED) terms of service. In other words, if we tried to fix the problem in Joomla's code — a problem which didn't originate from us, a problem we didn't and still don't have a say on — we would be kicked out of the JED, suffering a detrimental impact to our business. All we could do is discontinue this feature forever. Why forever? Because we want our software to work. The only way to do that is to avoid any third party code with a history of breaking without a fix being offered for weeks or months at a time.
Bugfixes in the NginX Conf Maker.
This version of Admin Tools will only work on Joomla 3.4 and later versions (3.5, 3.6 and 3.7).
We VERY STRONGLY advise you to update to the latest released version of Joomla! at all times. Admin Tools' support for older versions of Joomla! is only meant to be a temporary workaround while you're working on the update of your site.
Please note that we will only provide full support for the latest Joomla! version. Some features may not work at all in older Joomla! versions. We've thoroughly tested the security critical Web Application Firewall features against the supported versions of Joomla! as stated above and found them to be working properly.
Support for PHP 5.3 is discontinued. It's end of life since August 2014 and widely considered a security risk, unfit for production sites. Our software requires PHP 5.4 or later and is compatible with PHP 5.4, 5.5, 5.6, 7.0 and 7.1. Please note that as of January 2017 PHP 5.6 has entered the long term support phase: bugs are NOT fixed, only major security issues will be fixed. Therefore we strongly recommend using PHP 7.1.
We'd like to remind you that Joomla! 3.4 does NOT support PHP 7. PHP 7 is only supported by Joomla! 3.5.0 and later versions. Admin Tools will work perfectly fine (and very fast!) on a Joomla! 3.6 or later site running on PHP 7.1.