Download Our Latest Software

Admin Tools

version 4.0.1 Stable

Released on: Thursday, 28 July 2016 10:55

Release Notes

Release highlights

YOU MUST UPDATE THE PROFESSIONAL VERSION MANUALLY. Due to the changes in the packaging format and the way Joomla's extensions updater works the Download ID of the Professional release was not registered with Joomla. As a result any attempt to update Admin Tools from 4.0.0.b1, 4.0.0.b2, 4.0.0.rc1 or 4.0.0 to this version using the Joomla extensions updater will NOT work. You MUST download this new version and install it on your site like any other extension. This will address the update issue.

Several issues regarding passwords with non-alphanumeric characters were addressed in this release. These issues primarily affected the Master password and Administrator Password Protection features.

Updating from Admin Tools 3.5 or earlier could cause a PHP Fatal error due to a leftover file.

Joomla! 3.4, 3.5 and 3.6 only

This version of Admin Tools will only work on Joomla 3.4 and later versions, including the brand new Joomla 3.6.

We VERY STRONGLY advise you to update to the latest released version of Joomla! at all times. Admin Tools' support for older versions of Joomla! is only meant to be a temporary workaround while you're working on the update of your site.

Please note that we will only provide full support for the latest Joomla! version. Some features may not work at all in older Joomla! versions. We've thoroughly tested the security critical Web Application Firewall features against the supported versions of Joomla! as stated above and found them to be working properly.

PHP 5.4.0 or any later 5.x/7.x version is required

Support for PHP 5.3 is discontinued. It's end of life since August 2014 and widely considered a security risk, unfit for production sites. Our software requires PHP 5.4 or later and is compatible with PHP 5.4, 5.5, 5.6 and 7.0. We strongly recommend using PHP 5.6 or 7.0.

We'd like to remind you that Joomla! 3.4 does NOT support PHP 7. PHP 7 is only supported by Joomla! 3.5.0 and later versions. Admin Tools will work perfectly fine (and very fast!) on a Joomla! 3.6 or later site running on PHP 7.0.

Changelog

Bug fixes

  • [LOW] If you were living under a rock and hadn't updated to Admin Tools 3.6 or later the last 2 years you may get a fatal error after update to 4.0
  • [LOW] Layout / Javascript issues with IE11 on the Configure WAF page
  • [MEDIUM] Administrator Password Protection does not work with passwords containing special characters
  • [MEDIUM] Configure Permissions does not work with folder names containing special characters
  • [MEDIUM] Master password does not work with passwords containing special characters
  • [MEDIUM] PHP File Scanner's front-end scanning feature does not work with secret keys containing special characters

Critical bugs and important changes

  • YOU MUST UPDATE TO THIS RELEASE MANUALLY. The Download ID was not registered with Joomla, making updates from 4.0.0.b1, 4.0.0.b2, 4.0.0.rc1 and 4.0.0 impossible.

Release Files

Documentation (PDF)

admin-tools.pdf.zip

PDF

Download now

Admin Tools Core

pkg_admintools-4.0.1-core.zip

Joomla! 3.4 Joomla! 3.5 Joomla! 3.6 PHP 5.4 PHP 5.5 PHP 5.6 PHP 7.0

Download now

Cookies Notification - Action required

This website uses cookies to provide user authentication and improve your user experience. Please indicate whether you consent to our site placing these cookies on your device. You can change your preference later, from the controls which will be made available to you at the bottom of every page of our site.