Downloads

Akeeba Backup for Joomla!

Akeeba Backup for Joomla!

version 5.1.1 Stable

Released on: Thursday, 23 June 2016 10:09

Release Notes

What's new

Work around badly configured hosting environments. It has come to our attention that certain abysmal quality hosts are using the eAccelerator code caching PHP extension on PHP 5.4 and later versions. eAccelerator was abandoned in 2012 and never fully supported the new features in PHP 5.4 and later versions. As a result, any software using any PHP 5.4 and later features, such as Traits, will not work properly when you're using eAccelerator. This was the case with Akeeba Backup 5.0.0 to 5.1.0 inclusive. Even though this is your host's fault (they MUST NOT run end of life software on production web servers, let alone software that breaks the scripts running on the server) we decided to work around their wrong setup in our software. THIS IS NOT A PERMANENT THING. You will receive non-dismissable warnings until your host fixes their setup. Moreover Akeeba Backup 5.2.0 will DROP support for these broken servers and go full PHP 5.4 and later ONLY. You have been warned. Ask your host to fix their servers. DO NOT let them run out of date software on their servers which breaks your sites and can introduce security issues (make your sites easier to hack).

Joomla! 3.4 or later

We only support Joomla! 3.4 or later, including 3.5. We strongly advise you to run Joomla! 3.4.7 or later for security reasons. Older versions of Joomla! have known major security issues which are being actively exploited to hack sites. Do note that these security issues were fixed on Christmas Eve 2015 thanks to the effort of our development team who contributed their time and knowledge to make Joomla! more secure.

PHP 5.4.0 or any later 5.x/7.x version is required

Support for PHP 5.3 is discontinued. It's end of life since August 2014 and widely considered a security risk, unfit for production sites. Our software requries PHP 5.4 or later and is compatible with PHP 5.4, 5.5, 5.6 and 7.0. We strongly recommend using PHP 5.6 or 7.0.

Note: even though this version of our software will install and work on PHP 5.3.3 and later we WILL NOT provide support to anyone who is using PHP 5.3.

We'd like to remind you that Joomla! 3.4 does NOT support PHP 7. PHP 7 is only supported by Joomla! 3.5.0 and later versions. Akeeba Backup will work perfectly fine (and very fast!) on a Joomla! 3.5 or later site running on PHP 7.0.

Thank you, beta testers!

We want to sincerely thank all the people who took the time to download, install and test the two beta releases of Akeeba Backup 5.1.0. Their feedback has been invaluable in identifying and fixing all remaining bugs – including some obscure ones that have been there for several years. You guys and gals rock!

Changelog

Bug fixes

  • [HIGH] gh-592 Misleading 403 Access forbidden error when your Akeeba Backup tables are missing or corrupt.
  • [LOW] PHP warning in the File and Directories Exclusion page when the root is inaccessible / does not exist.
  • [LOW] Seldom fatal error when installing or updating (most likely caused by bad opcode optimization by PHP itself)

New features

  • Added optional filter to automatically exclude MyJoomla database tables

Miscellaneous changes

  • Better information about outdated PHP versions
  • Removed dependency on jQuery timers
  • Taking into account Joomla! 3.6's changes for the log directory location
  • Warn about broken eAccelerator
  • Work around broken hosts with invalid / no default server timezone in CLI scripts

Our Core versions are provided free of charge,
but they only scratch the surface of what's possible.

Subscribe today to get access to the exclusive features and enhanced support of our Professional releases!

Subscribe and get full access!

Already a subscriber? Log in.

Cookies Notification - Action required

This website uses cookies to provide user authentication and improve your user experience. Please indicate whether you consent to our site placing these cookies on your device. You can change your preference later, from the controls which will be made available to you at the bottom of every page of our site.