Downloads

Akeeba Backup for Joomla!

Akeeba Backup for Joomla!

version 5.5.1 Stable

Released on: Monday, 07 August 2017 01:37

What's new

Joomla! 3.7 compatibility. Unfortunately, Joomla! 3.7 was released with severe issues in several of its fundamental core APIs. While this is a series of bugs in Joomla! itself we did our best to work around them in a way which will minimise the probability of our software being affected by similar issues in the future.

Removing the automated update CLI script. This happens for two reasons. First, very few people were using it. Second, and most important, Joomla! broke the session handling which in turn breaks all CLI scripts. The only workaround to that is rewriting the application to NOT use any Joomla! core code that can even remotely touch JSession. Unfortunately, fetching and applying extension updates falls into the category of affected code. While we could write our own installation library for CLI updates this is expressly forbidden by the Joomla! Extension Directory (JED) terms of service. In other words, if we tried to fix the problem in Joomla's code — a problem which didn't originate from us, a problem we didn't and still don't have a say on — we would be kicked out of the JED, suffering a detrimental impact to our business. All we could do is discontinue this feature forever. Why forever? Because we want our software to work. The only way to do that is to avoid any third party code with a history of breaking without a fix being offered for weeks or months at a time.

Bug fixes. We didn't just work around Joomla's bugs, we fixed some bugs in our own code too. These are mostly edge cases. If you ever had a never ending backup eating up all your free space, fear not, we fixed it. Same goes if your backup crashed when backing up a database table with very large rows. Finally, we fixed the support for Joomla! 3.7's custom administrator menu items.

Joomla! 3.4 or later

We only support Joomla! 3.4 or later, including 3.5, 3.6 and 3.7. We strongly advise you to run the latest available version of Joomla! for security reasons. Older versions of Joomla! have known major security issues which are being actively exploited to hack sites.

PHP 5.4.0 or any later 5.x/7.x version is required

Support for PHP 5.3 has been discontinued. PHP 5.3 has been end of life since August 2014 and widely considered a security risk, unfit for production sites. Our software requries PHP 5.4 or later and is compatible with PHP 5.4, 5.5, 5.6, 7.0 and 7.1. We strongly recommend using PHP 5.6 or 7.0.

We'd like to remind you that Joomla! 3.4 does NOT support PHP 7. PHP 7 is only supported by Joomla! 3.5.0 and later versions. Akeeba Backup will work perfectly fine (and very fast!) on a Joomla! 3.5 or later site running on PHP 7.0.

Changelog

Critical bugs and important changes

  • The System - Backup on Update plugin may cause an error accessing the backend on some sites

Our Core versions are provided free of charge, but they only scratch the surface of what's possible. Subscribe today to get access to the exclusive features and enhanced support of our Professional releases!

Subscribe Already a subscriber? Log in.