Downloads

Akeeba Backup for Joomla!

Akeeba Backup for Joomla!

version 5.6.1 Stable

Released on: Monday, 11 December 2017 03:07

Release Notes

What's new

Better troubleshooting. We introduced a feature which will display detailed information about unexpected exceptions and, if you are using PHP 7, any PHP fatal errors in the backend of your site. When requesting support you can give us this information to help us help you faster and more accurately.

BackBlaze support. On popular demand we added support for the low-cost and high reliability storage provider BackBlaze.

PHP 7.2 support. Our software now runs on PHP 7.2.

We updated the Dropbox API with the new "_v2" endpoints where applicable. Dropbox has been rolling out updated endpoints for several features. Our software is now using the new endpoints where available, ensuring forward compatibility.

Bug fixes. We have addressed known issues, mostly low priority ones. Please consult the CHANGELOG.

Joomla! 3.4 or later

We only support Joomla! 3.4 or later, including 3.5, 3.6, 3.7 and 3.8. We strongly advise you to run the latest available version of Joomla! for security reasons. Older versions of Joomla! have known major security issues which are being actively exploited to hack sites.

This version of our software DOES NOT run on Joomla! 4. A new, rewritten and improved version with support for Joomla! 4 will be released in the near future.

PHP 5.4.0 or any later 5.x/7.x version is required

Support for PHP 5.3 has been discontinued. PHP 5.3 has been end of life since August 2014 and widely considered a security risk, unfit for production sites. Our software requries PHP 5.4 or later and is compatible with PHP 5.4, 5.5, 5.6, 7.0, 7.1 and 7.2. We strongly recommend using PHP 5.6 or 7.1.

We'd like to remind you that Joomla! 3.4 does NOT support PHP 7. PHP 7 is only supported by Joomla! 3.5.0 and later versions. Akeeba Backup will work perfectly fine (and very fast!) on a Joomla! 3.5 or later site running on PHP 7.0.

Changelog

Bug fixes

  • [LOW] Backup On Update was available on Pro version only. Now it's available in the Core version, too.
  • [LOW] Calendar fields did not display the month due to a Joomla! 3.7+ CSS-related bug
  • [LOW] Core version: some post-processing options were displayed even though the code to make them work was not present.
  • [LOW] Programmatically triggering mouse events could fail in some browsers, e.g. newer versions of Firefox
  • [LOW] The ANGIE Password option in Configuration and Backup Now pages didn't show up in the Core release
  • [LOW] WebDav post-processing: Fixed issue with hosts without a valid certificate file and SSL connections
  • [MEDIUM] "Apply to all" filter button does not work due to a Javascript issue
  • [MEDIUM] Backing up to JPS with a static salt using the JSON API would always fail

New features

  • BackBlaze B2 integration (Pro only)
  • Display info about exceptions and PHP 7+ fatal errors in the backend

Miscellaneous changes

  • JSON API stepBackup: now enforcing the check for the MANDATORY parameter "backupid"
  • PHP 7.2 compatibility: renaming Object class to BaseObject
  • Update Dropbox API with the new "_v2" endpoints where applicable

Release Files

Documentation in PDF format

akeeba-backup-guide.pdf.zip

PDF

Download now

Akeeba Backup Core installation package

pkg_akeeba-5.6.1-core.zip

Joomla! 3.4 Joomla! 3.5 Joomla! 3.6 Joomla! 3.7 Joomla! 3.8 PHP 5.4 PHP 5.5 PHP 5.6 PHP 7.0 PHP 7.1

Download now

Our Core versions are provided free of charge, but they only scratch the surface of what's possible. Subscribe today to get access to the exclusive features and enhanced support of our Professional releases!

Subscribe Already a subscriber? Log in.

Cookies Notification - Action required

This website uses cookies to provide user authentication and improve your user experience. Please indicate whether you consent to our site placing these cookies on your device. You can change your preference later, from the controls which will be made available to you at the bottom of every page of our site.