Downloads

Akeeba Backup for Joomla!

Akeeba Backup for Joomla!

version 6.3.1 Stable

Released on: Monday, 26 November 2018 04:43

Release Notes

What's new

Workaround for buggy cURL versions breaking Google Drive uploads. Newer cURL versions introduced a change in behavior when talking to HTTPS servers. This causes a conflict with Google Drive's API server, leading to failure to upload there. This version addresses this issue in cURL by forcing HTTP/1.1 communications with Google's API server, bypassing the issue caused by cURL. Older cURL versions are not affected and will see no change in behavior from this fix.

Site Transfer Wizard improvements. The Site Transfer Wizard will now detect and report DNS issues and issues with invalid or self-signed SSL certificates instead of showing a generic error message that your configuration does not correspond to the site you are trying to restore to. Moreover, we addressed issues which prevented using FTP/SFTP to upload chunks of the backup archive to the remote server instead of HTTP/HTTPS API calls. This will result in a much better experience and increase compatibility with a much larger number of hosting providers.

Bug fixes. We have addressed several issues. Please consult the CHANGELOG.

Joomla! 3.4 or later

We only support Joomla! 3.4 or later, including 3.5, 3.6, 3.7, 3.8 and 3.9. We strongly advise you to run the latest available version of Joomla! for security reasons. Older versions of Joomla! have known major security issues which are being actively exploited to hack sites.

HEADS UP! We only test our software with the last two released Joomla! version branches.

PHP 5.4.0 or any later 5.x/7.x version is required

Support for PHP 5.3 has been discontinued. PHP 5.3 has been end of life since August 2014 and widely considered a security risk, unfit for production sites. Our software requires PHP 5.4 or later and is compatible with PHP 5.4, 5.5, 5.6, 7.0, 7.1 and 7.2. We currently offer preliminary support for PHP 7.3 which at the time of this writing is still in Release Candidate (testing) phase. We strongly recommend using PHP 7.2.

We'd like to remind you that Joomla! 3.4 does NOT support PHP 7. PHP 7 is only supported by Joomla! 3.5.0 and later versions.

HEADS UP! We will be dropping support for PHP 5.4, 5.5 and 7.0 starting January 2019. The software might run on these obsolete versions of PHP but we will be no longer officially supporting them. Any issues which can only be reproduced on non-supported PHP versions will not be treated as bugs and won't be fixed.

Changelog

Bug fixes

  • [HIGH] Site Transfer Wizard: uploading the backup archive through FTP/SFTP had mulitple issues preventing its operation
  • [LOW] We should no longer attempt to load the obsolete Encryption.min.js file
  • [MEDIUM] Restoration: Invalid redirection after deleting the installation directory when not using Kickstart or the integrated restoration

Miscellaneous changes

  • Site Transfer Wizard: detect and report wrong DNS setup and invalid SSL certifications instead of a generic error
  • Workaround for buggy cURL versions breaking Google Drive uploads

Release Files

Documentation in PDF format

akeeba-backup-guide.pdf.zip

PDF

Download now

Akeeba Backup Core installation package

pkg_akeeba-6.3.1-core.zip

Joomla! 3.4 Joomla! 3.5 Joomla! 3.6 Joomla! 3.7 Joomla! 3.8 Joomla! 3.9 PHP 5.4 PHP 5.5 PHP 5.6 PHP 7.0 PHP 7.1 PHP 7.2 PHP 7.3

Download now

Our Core versions are provided free of charge,
but they only scratch the surface of what's possible.

Subscribe today to get access to the exclusive features and enhanced support of our Professional releases!

Subscribe and get full access!

Already a subscriber? Log in.

Cookies Notification - Action required

This website uses cookies to provide user authentication and improve your user experience. Please indicate whether you consent to our site placing these cookies on your device. You can change your preference later, from the controls which will be made available to you at the bottom of every page of our site.