Downloads

Akeeba Ticket System

Akeeba Ticket System

version 2.2.2 Stable

Released on: Thursday, 28 July 2016 12:07

Release Notes

Release highlights

The Components menu item would sometimes disappear from the administrator back-end. We now trained it better so it will obey when we tell them to "Stay!".

Auto-replies would be sent repeatedly to the same ticket every time the client replied. We have disciplined the misbehaving robot and it will now only reply once per ticket.

Canned Replies would appear out of order in the front-end. Apparently most of you didn't appreciate the playful hide-and-seek mood of this bug... er... unexpected feature. Now all canned replies will appear in the sort order you've defined in the back-end of the component.

The following highlights refer to the entire 2.2.x release branch.

Work around Joomla 3.5/3.6 mail issues. If your site's Email From address in Global Configuration or your user's email address were malformed Joomla would crash when trying to send out emails. This could result in ticket/reply creation by email not working among other things. This is a backwards incompatible change in Joomla 3.5 and later that we have already reported to Joomla but they decided not to revert it. Therefore we are now working around it.

Small new features:

  • Redirect to login page when a guest user tries to file a new ticket.
  • User overridable templates for the Akeeba Ticket System - Tickets info module.
  • Custom sh404SEF plugin which generates the same kind of URLs as the Joomla! SEF router.
  • Non-SEF URLs generated by ATS 1.x are now automatically mapped and work with ATS 2.x
  • Plugin to displaying the user's avatar using the EasySocial user avatar

PHP 5.4, 5.5, 5.6 or 7.0 is required

This version requires PHP 5.4.0 or later including 5.4, 5.5, 5.6 or 7.0. PHP 5.3 is no longer supported. We strongly advise you to use PHP 5.6 or 7.0. Support for older versions of PHP will be dropped in the next few months.

Joomla! 3.x up to 3.4 does NOT run on PHP 7.0. We only support using our software on PHP 7.0 with Joomla! 3.5.

Joomla! 3.4, 3.5 and 3.6 is supported

This version of our software can be installed on Joomla! 3.4.x, 3.5.x or 3.6.x. It is not compatible with end-of-life Joomla! 1.x, 2.5, or 3.0 to 3.3 releases (inclusive). If you are using an old Joomla! version please upgrade to the latest Joomla! 3 version available from Joomla.org.

Changelog

Bug fixes

  • [LOW] Canned replies in front-end do not respect the ordering (gh-164)
  • [MEDIUM] Auto-replies feature will keep replying to the ticket every time the user replies to it (gh-162)
  • [MEDIUM] The backend menu item could disappear sometimes from the Joomla components menu (gh-163)

Release Files

Documentation (PDF)

ats-guide.pdf.zip

PDF

Download now

Akeeba Ticket System Core

pkg_ats-2.2.2-core.zip

Joomla! 3.4 Joomla! 3.5 Joomla! 3.6 PHP 5.4 PHP 5.5 PHP 5.6 PHP 7.0

Download now

Our Core versions are provided free of charge,
but they only scratch the surface of what's possible.

Subscribe today to get access to the exclusive features and enhanced support of our Professional releases!

Subscribe and get full access!

Already a subscriber? Log in.

Cookies Notification - Action required

This website uses cookies to provide user authentication and improve your user experience. Please indicate whether you consent to our site placing these cookies on your device. You can change your preference later, from the controls which will be made available to you at the bottom of every page of our site.