Downloads

Akeeba Ticket System

Akeeba Ticket System

version 2.3.0 Stable

Released on: Thursday, 18 May 2017 09:05

What's new?

Joomla! 3.7 compatibility. Unfortunately, Joomla! 3.7 was released with severe issues in several of its fundamental core APIs. While this is a series of bugs in Joomla! itself we did our best to work around them in a way which will minimise the probability of our software being affected by similar issues in the future.

Removing the automated update CLI script. This happens for two reasons. First, very few people were using it. Second, and most important, Joomla! broke the session handling which in turn breaks all CLI scripts. The only workaround to that is rewriting the application to NOT use any Joomla! core code that can even remotely touch JSession. Unfortunately, fetching and applying extension updates falls into the category of affected code. While we could write our own installation library for CLI updates this is expressly forbidden by the Joomla! Extension Directory (JED) terms of service. In other words, if we tried to fix the problem in Joomla's code — a problem which didn't originate from us, a problem we didn't and still don't have a say on — we would be kicked out of the JED, suffering a detrimental impact to our business. All we could do is discontinue this feature forever. Why forever? Because we want our software to work. The only way to do that is to avoid any third party code with a history of breaking without a fix being offered for weeks or months at a time.

Caching issues could cause strange issues when you are logged in. Now the pages of the component are not cached -or at least we ask Joomla! to not cache them- when you are logged in. This is the same behaviour as Joomla's Articles component: if you're logged in you are never served cached pages.

Bug fixes. Some relatively benign issues were addressed in this release.

PHP 5.4, 5.5, 5.6 or 7.0 is required

This version requires PHP 5.4.0 or later including 5.4, 5.5, 5.6 or 7.0. PHP 5.3 is no longer supported. We strongly advise you to use PHP 5.6 or 7.0. Support for older versions of PHP will be dropped in the next few months.

Joomla! 3.x up to 3.4 does NOT run on PHP 7.0. We only support using our software on PHP 7.0 with Joomla! 3.5.

Joomla! 3.4, 3.5 and 3.6 is supported

This version of our software can be installed on Joomla! 3.4.x, 3.5.x or 3.6.x. It is not compatible with end-of-life Joomla! 1.x, 2.5, or 3.0 to 3.3 releases (inclusive). If you are using an old Joomla! version please upgrade to the latest Joomla! 3 version available from Joomla.org.

Changelog

Bug fixes

  • [LOW] PHP warning in backend Tickets category if you've deleted the category a ticket was opened in.
  • [MEDIUM] "No new tickets" setting not respected by the New Ticket view when a category is not specified yet.
  • [MEDIUM] Caching would lead to strange issues when you are logged in (ticket status not updating, not seeing replies, 403 error closing a ticket etc)
  • [MEDIUM] The Download ID was not applied, making automatic updates impossible (you can still update manually).

Removed features

  • Removing the automatic update CLI script. Joomla! 3.7.0 can no longer execute extension installation under a CLI application.

Critical bugs and important changes

  • Joomla! 3.7.0 has a broken System - Page Cache plugin leading to white pages and wrong redirections

Our Core versions are provided free of charge, but they only scratch the surface of what's possible. Subscribe today to get access to the exclusive features and enhanced support of our Professional releases!

Subscribe Already a subscriber? Log in.