Forgot your username?             Forgot your password?

DocImport

Akeeba DocImport is a component which produces cross-linked documentation out of DocBook XML sources. It's what we are using to power our own site's documentation (a.k.a. Docs) section.

Stable 1.0.7

Maturity:
Stable
Released on:
Sunday, 09 March 2014 09:10
Viewed:
150 times

This is a bugfix release, addressing known minor issues in the previous versions. We recommend that all of our users upgrade.

IMPORTANT! This version requires PHP 5.3, 5.4 or 5.5 and Joomla! 2.5.6+ or 3.2. It won't install on PHP 5.2 or earlier, or Joomla! 2.5.0 up to and including 2.5.5. This version is compatible with Joomla! 2.5.6+ as well as Joomla! 3.2. Please read the release notes.

PHP 5.3, 5.4 or 5.5 is now required

This version requires PHP 5.3, 5.4 or 5.5. The rationale behind this is explained in our statement of mid-February 2013. It won't install on hosts running PHP 5.2 or earlier. Moreover, due to the necessary Joomla! API changes found only in Joomla! 2.5.6 or later, this version will not install on Joomla! 2.5.5 or earlier versions. In any case, it will tell you exactly why it cannot be installed (minimum PHP or Joomla! version not satisfied).

Changelog

Bug fixes

  • [LOW] Fixed page headings
  • [LOW] Very rarely an empty article would be generated every time you tried processing the DocBook XML files
  • [MEDIUM] Fatal error com_finder indexer
  • [MEDIUM] Fatal error com_finder indexer. Thanks Jurian!
  • [MEDIUM] The plugins didn't install
  • [MEDIUM] The plugins didn't install. Thanks Jurian!

Miscellaneous changes

  • AJAX ordering now shows the ordering in a textbox, to faciliate ordering without much frustration in Joomla! 3
  • Improved back-end display in Joomla! 3
  • Now using the built-in Joomla! extensions updater instead of Live Update to deliver updates

Take me to the downloads for this version

Stable 1.0.6

Maturity:
Stable
Released on:
Tuesday, 10 September 2013 14:20
Viewed:
612 times

IMPORTANT! This version requires PHP 5.3 or later and Joomla! 2.5.6 or later. It won't install on PHP 5.2 or earlier, or Joomla! 2.5.0 up to and including 2.5.5. This version is compatible with Joomla! 2.5.6+ as well as Joomla! 3.0. Please read the release notes.

This is a bugfix addressing known issues in the previous version. We recommend that all of our users upgrade. If you have trouble upgrading, please consult our troubleshooting instructions for February 2013 releases page.

General information

If you have a problem after or before installing the component please read our troubleshooting page for the February 2013 releases of our components. Do note that these issues are only likely to affect users with old versions of PHP, Joomla! and/or very old versions of our components.

PHP 5.3 is now required

This version requires PHP 5.3 or later. The rationale behind this is explained in our statement of mid-February 2013. It won't install on hosts running PHP 5.2 or earlier. Moreover, due to the necessary Joomla! API changes found only in Joomla! 2.5.6 or later, this version will not install on Joomla! 2.5.5 or earlier versions. In any case, it will tell you exactly why it cannot be installed (minimum PHP or Joomla! version not satisfied).

Take me to the downloads for this version

Stable 1.0.5

Maturity:
Stable
Released on:
Monday, 09 September 2013 08:16
Viewed:
357 times

IMPORTANT! This version requires PHP 5.3 or later and Joomla! 2.5.6 or later. It won't install on PHP 5.2 or earlier, or Joomla! 2.5.0 up to and including 2.5.5. This version is compatible with Joomla! 2.5.6+ as well as Joomla! 3.0. Please read the release notes.

This is a bugfix addressing known issues in the previous version. We recommend that all of our users upgrade. If you have trouble upgrading, please consult our troubleshooting instructions for February 2013 releases page.

General information

If you have a problem after or before installing the component please read our troubleshooting page for the February 2013 releases of our components. Do note that these issues are only likely to affect users with old versions of PHP, Joomla! and/or very old versions of our components.

PHP 5.3 is now required

This version requires PHP 5.3 or later. The rationale behind this is explained in our statement of mid-February 2013. It won't install on hosts running PHP 5.2 or earlier. Moreover, due to the necessary Joomla! API changes found only in Joomla! 2.5.6 or later, this version will not install on Joomla! 2.5.5 or earlier versions. In any case, it will tell you exactly why it cannot be installed (minimum PHP or Joomla! version not satisfied).

Changelog

Bug fixes

  • [LOW] CLI CRON scripts not fully compatible with PHP CGI
  • [LOW] Links to index.html are not replaced

Take me to the downloads for this version