Downloads

Official Releases

Admin Tools

version 5.5.0 Stable

Released on: Friday, 03 January 2020 04:26

Release Notes

What's new?

Removed GeoGraphic IP blocking due to changes in MaxMind's policy. MaxMind removed public downloads of the GeoIP library. We are removing the GeoIP-related features in our software per our announcement. Practically, this means that Geographic IP Blocking is removed and emails from Admin Tools will no longer include the country and continent of the IP address being blocked.

Removed System - Admin Tools Joomla! Update Email plugin. This feature has been contributed to Joomla! itself a long time ago. Since we no longer support any versions of Joomla which don't have this plugin built in we have no reason including it in Admin Tools.

IP Workarounds: added new value "auto" for automatically detecting and enabling them if required. This is less complicated that it sounds. If we detect that the IP addresses being blocked belong to a private network or CloudFlare we will automatically enable IP Workarounds for your site.

Common PHP version warning scripts. We have normalized the wording of warnings about old, End of Life and dangerously old PHP versions. You will get a reminder to update PHP if it has entered its final year of support, a warning to update PHP if it has recently become End of Life, a much more urgent warning if it's been End of Life for over 6 months and an error if it's no longer supported by our software.

Refactored backend code for the "Change Database Collation" feature.. This will now work more reliably and a bit faster on most sites.

Improved Dark Mode. If you're using a browser and OS that supports dark mode with a dark administrator template you can enjoy a much improved dark theme CSS for Admin Tools.

Bug fixes and minor improvements. Please take a look at the CHANGELOG below.

Joomla! versions supported

We only officially support using our software with the latest Joomla! release branch, 3.9. We strongly advise you to run the latest available version of Joomla! for security reasons. Older versions of Joomla! have known major security issues which are being actively exploited to hack sites.

Our software should still run on Joomla! 3.8. However, we do not test with these versions and we no longer treat breaking support for these obsolete versions of Joomla! as a bug.

PHP versions supported

We only officially support using our software with PHP 5.6, 7.2, 7.3 or 7.4. We strongly advise you to run the latest available version of PHP on a branch currently maintained by the PHP project for security reasons. Older versions of PHP have known major security issues which are being actively exploited to hack sites and they have stopped receiving security updates, leaving you exposed to these issues.

Our software should still run on PHP 7.0 and 7.1. However, we do not test with these versions and we no longer treat breaking support for these obsolete PHP versions of PHP as a bug.

Support for PHP 5.6 will be removed once Joomla 4, with a minimum requirement for PHP 7, is released.

Please note that earlier PHP versions including but not limited to PHP 5.3, 5.4 and 5.5 are no longer supported and our software no longer works on them.

Changelog

Bug fixes

  • [HIGH] CLI (CRON) scripts could sometimes stop with a Joomla crash due to Joomla's mishandling of the session under CLI.
  • [HIGH] New installations may get a SQL error on installation or trying to access the component
  • [LOW] Exception thrown when blocking an attack with a customisable error page if the blocked request had already set the 'layout' request parameter
  • [LOW] Troubleshooting email on administrative functions was always sent, regardless of the option's setting

New features

  • Common PHP version warning scripts
  • IP Workarounds: added new value "auto" for automatically detecting and enabling them if required

Miscellaneous changes

  • Improved Dark Mode
  • Refactored backend code for the "Change Database Collation" feature.

Removed features

  • Removed GeoGraphic IP blocking due to changes in MaxMind's policy (see our site's News section)
  • Removed System - Admin Tools Joomla! Update Email plugin. This feature has been contributed to Joomla itself a long time ago

Release Files

Documentation (PDF)

admin-tools.pdf.zip

PDF

Download now

Admin Tools Core

pkg_admintools-5.5.0-core.zip

Joomla! 3.8 Joomla! 3.9 PHP 5.6 PHP 7.0 PHP 7.1 PHP 7.2 PHP 7.3 PHP 7.4

Download now

Our Core versions are provided free of charge,
but they only scratch the surface of what's possible.

Subscribe today to get access to the exclusive features and enhanced support of our Professional releases!

Subscribe and get full access!

Already a subscriber? Log in.

Cookies Notification - Action required

This website uses cookies to provide user authentication and improve your user experience. Please indicate whether you consent to our site placing these cookies on your device. You can change your preference later, from the controls which will be made available to you at the bottom of every page of our site.