Support

Akeeba Backup for Joomla!

#28964 – remote ssh error

Posted in ‘Akeeba Backup for Joomla!’
This is a public ticket. Everybody will be able to see its contents. Do not include usernames, passwords or any other sensitive information.
Sunday, 07 January 2018 05:20 CST
I want to configure the backup-profile to upload my backup to a sftp-server.
Whenever I try to test the connection, I get an error-message "Could not connect to the remote SFTP server. The error message was: Y".
I want to send the backup of a public webserver (hosted at 1&1 in Germany) to a NAS in my local network. The NAS is accessible from the Internet. I've tested this with FileZilla from another computer.

I've tried the post-processing engines "Upload to Remote SFTP (SSH) server" as well as "Upload to Remote SFTP (SSH) server using cURL". Both show the same error.
PHPInfo show "libssh2/1.4.3" in section "CURL".

I hope, you can help me with this problem.

Kind regards,

Michael
Custom Fields
Joomla! version (in x.y.z format)
3.8.2
PHP version (in x.y.z format)
7.1.12
Akeeba Backup version (x.y.z format)
5.6.3
Edited by idee-design on 2018-01-07 11:20
Sunday, 07 January 2018 23:59 CST
If both options throw the same nondescript error I would suspect that there is a firewall at play.

You have already confirmed that there is no firewall blocking access on the NAS side since you can connect from a different computer over the Internet. If this is not the case and you only tried connecting from a computer on the same network as the NAS please try connecting to your NAS over the Internet. Simple solution for this test: tether your laptop to your phone's 3G / 4G data connection and try accessing your NAS.

While you're at this, let's also confirm that your NAS does implement an SFTP protocol that PHP (through either the SSH2 or the cURL library) can access. On the same Internet-connected laptop set up a local server (e.g. XAMPP, WAMPServer, MAMP, ...), install Joomla and Akeeba Backup and set up the transfer over SSH. Please note that you may only see the cURL option; the SSH2 module for PHP only became stable as of PHP 7.1 and not all local host packages include it even to this date.

If there is no issue on the NAS side, we might have a firewall on the server side, blocking outbound connections. If I recall correctly that's the default configuration of 1&1. Please ask your host to let you access your NAS over SSH. You will need to provide them the port you're using on your NAS and its (static) IP address.




Nicholas K. Dionysopoulos


Lead Developer and Director






Greek: native


English: excellent


French: basic






Please keep in mind my timezone and cultural differences when reading my replies. Thank you!






Wednesday, 07 February 2018 17:17 CST
This ticket has been automatically closed. All tickets which have been inactive for a long time are automatically closed. If you believe that this ticket was closed in error, please contact us.
Edited by on 2018-02-07 23:17
This ticket is closed, therefore read-only. You can no longer reply to it. If you need to provide more information, please open a new ticket and mention this ticket's number.

Support Information

Working hours: Typically we work Monday to Friday, 9am to 7pm Cyprus timezone (EEST). Support is provided by the same developers writing the software, all of which live in Europe. You can still file tickets, but we cannot respond to them, outside of our working hours.

Support policy: Read the complete support policy which is part of our Terms of Service. We kindly remind our subscribers that they have already explicitly and unconditionally accepted the Terms of Service.

Cookies Notification - Action required This website uses cookies to provide user authentication and improve your user experience. Please indicate whether you consent to our site placing these cookies on your device. You can change your preference later, from the controls which will be made available to you at the bottom of every page of our site.