Downloads

Akeeba Backup for Joomla!

Akeeba Backup for Joomla!

version 4.5.5 Stable

Released on: Friday, 19 February 2016 14:56

Release highlights

The file integrity check feature would fail on some servers because Joomla! randomly forgets to install a low importance plugin (the update notification email plugin). Unfortunately the only fix we can provide is disabling the file integrity / self-check feature of Akeeba Backup.

The backup check quick icon now launches a single click backup. Also, Improved display of the icon plugin.

Added option to automatically exclude hosting web stats (e.g. Webalyzer)

IMPORTANT! Behaviour change. The enryption of JPS archives was improved. As a result you need to use Kickstart 4.1.3 or later and UNiTE 2.0.2 or later to extract JPS archives taken with Akeeba Backup 4.5.2 and later. At this point Akeeba eXtract Wizard DOES NOT support the new improved JPS archive format. No further updates to eXtract Wizard are planned.

IMPORTANT! Behaviour change. All remote backup features (front-end URL, JSON API) will be automatically disabled if you are using a Secret Word that's not strong enough. This is done to protect your against brute forcing of the Secret Word which could allow attackers to take and download backups of your sites. Please read our release announcement for more information.

Integrated updater to be optionally used instead of Joomla!'s own extensions updater. Please note that under Joomla! 1.6, 1.7, 2.5, 3.0 and 3.1 you do not have a choice: you will use the integrated updater instead of Joomla!'s. If you try using Joomla!'s extensions updater under these old versions of Joomla! to update Akeeba Backup Professional you will get an error.

Extended Joomla! and PHP support. We now support Joomla! 1.6, 1.7, 2.5, 3.0, 3.1, 3.2, 3.3, 3.4 and 3.5 running on PHP 5.3.03 or later including PHP 5.4, 5.5, 5.6 and 7.0. Please note that not all versions of Joomla! run on all versions of PHP. Furthermore, we do NOT support PHP 5.2 even though older versions of Joomla! may run on it. If unsure please check our Compatibility page.

Joomla! 1.6 or later

This is not a typo! After considering the vast amount of changes in third party services Akeeba Backup integrates with (such as Dropbox and Amazon S3) we decided to reinstate compatibility with Joomla! 1.6, 1.7, 2.5, 3.0, 3.1, 3.2, 3.3 and also support the current Joomla! version 3.4 and the upcoming 3.5.

Please note that we do NOT recommend using Joomla! 1.x / 2.x or 3.0 to 3.3 inclusive on production sites due to major security issues.

PHP 5.3.3 or later 5.x version is required

The minimum required PHP version is 5.3.03. All versions of PHP from 5.3.03 onwards are supported, including 5.4, 5.5, 5.6 and the just released PHP 7.0. The component will not work on PHP 5.2 or earlier and will, in fact, refuse to install on it. We'd like to remind you that Joomla! 3.4 and earlier does NOT support PHP 7. Joomla! 3.5 (currently in beta) does support PHP 7. Akeeba Backup will work just fine in a Joomla! 3.5 site running on PHP 7.0.

Note: there is no such thing as PHP 6. PHP versions jumped from 5.6 to 7.0. Why? Well, it's a long story. TL;DR: It doesn't have to make sense, just accept it.

Changelog

Critical bugs and important changes

  • The file integrity check feature would fail on some hosts due to Joomla!'s installer being broken. The feature was removed.

Our Core versions are provided free of charge, but they only scratch the surface of what's possible. Subscribe today to get access to the exclusive features and enhanced support of our Professional releases!

Subscribe Already a subscriber? Log in.