Akeeba Backup for Joomla!

Want more?

Our Core versions are provided free of charge, but they only scratch the surface of what's possible. Subscribe today to get access to the exclusive features and enhanced support of our Professional releases!

Subscribe Already a subscriber? Log in.

Akeeba Backup for Joomla! 5.2.5 Stable

Released on: Sunday, 11 December 2016 18:00

 

What's new

This version addresses known issues which could affect usability, site transfers and restoring backups under some uncommon conditions.

Furthermore, this version adds support for conducting FTP, FTPS and SFTP file transfers using the cURL module for PHP. This is the same module used by evey other post-processing engine we're using such as Amazon S3, Dropbox, OneDrive, Google Drive and so on. That is to say, we already know it's rock solid and widely available, making it the best choice for conducting file transfers. The new file transfers over cURL are implemented in the Site Transfer Wizard and the new DirectFTP and DirectSFTP over cURL archivers. The Professional version of our software also implements that in the two new Upload to FTP / SFTP server over cURL post-processing engines.

Joomla! 3.4 or later

We only support Joomla! 3.4 or later, including 3.5. We strongly advise you to run the latest available version of Joomla! for security reasons. Older versions of Joomla! have known major security issues which are being actively exploited to hack sites.

PHP 5.4.0 or any later 5.x/7.x version is required

Support for PHP 5.3 has been discontinued. PHP 5.3 has been end of life since August 2014 and widely considered a security risk, unfit for production sites. Our software requries PHP 5.4 or later and is compatible with PHP 5.4, 5.5, 5.6 and 7.x. We strongly recommend using PHP 5.6 or 7.x.

We'd like to remind you that Joomla! 3.4 does NOT support PHP 7. PHP 7 is only supported by Joomla! 3.5.0 and later versions. Akeeba Backup will work perfectly fine (and very fast!) on a Joomla! 3.5 or later site running on PHP 7.

Akeeba Backup Core installation package

Joomla! 3.3 Joomla! 3.4 Joomla! 3.5 Joomla! 3.6 PHP 5.4 PHP 5.5 PHP 5.6 PHP 7.0

pkg_akeeba-5.2.5-core.zip Download now

 

Downloaded
41887 times
Compatibility
Joomla! 3.3 Joomla! 3.4 Joomla! 3.5 Joomla! 3.6 PHP 5.4 PHP 5.5 PHP 5.6 PHP 7.0

Installation package for Akeeba Backup Core, the free of charge version of Akeeba Backup without any of the advanced features.

Important! Akeeba Backup REQUIRES PHP 5.4, 5.5, 5.6 or 7.0. If your site is still running on an older PHP version, you are advised to upgrade immediately.

Items per page: