Downloads

Akeeba Backup for Joomla!

Akeeba Backup for Joomla!

version 5.3.4 Stable

Released on: Sunday, 30 April 2017 12:58

What's new

Rewritten Javascript. We have rewritten all the client-side code to use native Javascript instead of jQuery. One less hard dependency means easier code to maintain. As it's been the case since 2012, our software only supports Internet Explorer 9 or better and all modern browsers (Chrome, Firefox, Opera, Safari, ...).

Support for Joomla! 3.7 backend menu manager. The upcoming version of Joomla, 3.7, has an interesting new feature: it allows you to create custom backend (administrator) menus. Akeeba Backup is the FIRST third party extension to embrace this new feature. You can now create one-click backup menu items as well as menu items to Akeeba Backup's control panel, Manage Backups page and even the Site Transfer Wizard.

More secure JPS 2.0 backup format. We have upgraded the security of the JPS archive format by using PBKDF2 to create an encryption key from your password instead of the old method of password self-encryption. This greatly increases the security of shorter passwords. Moreover, passwords over 16 bytes are now fully taken into account (previous versions internally truncated passwords at 16 bytes). You will need Kickstart 5.3.0 or later to extract these archives. A new version of Akeeba eXtract Wizard will also be released soon as the current version is not compatible with the new JPS archives.

Supporting additional S3 regions. Canada and London regions are now supported.

Better support for sites using different database technologies. If you have a site with two or more databases using different database server technologies (MySQL, PostgreSQL, SQL Server) you will now be able to back them up even if you choose the Native database dump engine.

Joomla! 3.4 or later

We only support Joomla! 3.4 or later, including 3.5, 3.6 and 3.7. We strongly advise you to run the latest available version of Joomla! for security reasons. Older versions of Joomla! have known major security issues which are being actively exploited to hack sites.

PHP 5.4.0 or any later 5.x/7.x version is required

Support for PHP 5.3 has been discontinued. PHP 5.3 has been end of life since August 2014 and widely considered a security risk, unfit for production sites. Our software requries PHP 5.4 or later and is compatible with PHP 5.4, 5.5, 5.6, 7.0 and 7.1. We strongly recommend using PHP 5.6 or 7.0.

We'd like to remind you that Joomla! 3.4 does NOT support PHP 7. PHP 7 is only supported by Joomla! 3.5.0 and later versions. Akeeba Backup will work perfectly fine (and very fast!) on a Joomla! 3.5 or later site running on PHP 7.0.

Changelog

Bug fixes

  • [MEDIUM] Integrated restoration leads to an error message about the file extension being wrong

Our Core versions are provided free of charge, but they only scratch the surface of what's possible. Subscribe today to get access to the exclusive features and enhanced support of our Professional releases!

Subscribe Already a subscriber? Log in.