Forgot your username?             Forgot your password?

Want more?

Our Core versions are provided free of charge, but they only scratch the surface of what's possible. Subscribe today to get access to the exclusive features and enhanced support of our Professional releases!

Subscribe Already a subscriber? Log in.

Akeeba Ticket System

Version 2.2.3 Stable

Released on: Sunday, 11 December 2016 18:00

 

Maturity
Stable
Released on
Sunday, 11 December 2016 18:00
Viewed
0 times

This release adds a few minor features and improves the overall stability of the component under Joomla! 3.5 and 3.6.

What's new?

This version fixes issues we discovered after the last release, improving your experience with our software.

PHP 5.4, 5.5, 5.6 or 7.0 is required

This version requires PHP 5.4.0 or later including 5.4, 5.5, 5.6 or 7.0. PHP 5.3 is no longer supported. We strongly advise you to use PHP 5.6 or 7.0. Support for older versions of PHP will be dropped in the next few months.

Joomla! 3.x up to 3.4 does NOT run on PHP 7.0. We only support using our software on PHP 7.0 with Joomla! 3.5.

Joomla! 3.4, 3.5 and 3.6 is supported

This version of our software can be installed on Joomla! 3.4.x, 3.5.x or 3.6.x. It is not compatible with end-of-life Joomla! 1.x, 2.5, or 3.0 to 3.3 releases (inclusive). If you are using an old Joomla! version please upgrade to the latest Joomla! 3 version available from Joomla.org.

Take me to the downloads for this version

Version 2.2.2 Stable

Released on: Thursday, 28 July 2016 12:07

 

Maturity
Stable
Released on
Thursday, 28 July 2016 12:07
Viewed
0 times

This release adds a few minor features and improves the overall stability of the component under Joomla! 3.5 and 3.6.

Release highlights

The Components menu item would sometimes disappear from the administrator back-end. We now trained it better so it will obey when we tell them to "Stay!".

Auto-replies would be sent repeatedly to the same ticket every time the client replied. We have disciplined the misbehaving robot and it will now only reply once per ticket.

Canned Replies would appear out of order in the front-end. Apparently most of you didn't appreciate the playful hide-and-seek mood of this bug... er... unexpected feature. Now all canned replies will appear in the sort order you've defined in the back-end of the component.

The following highlights refer to the entire 2.2.x release branch.

Work around Joomla 3.5/3.6 mail issues. If your site's Email From address in Global Configuration or your user's email address were malformed Joomla would crash when trying to send out emails. This could result in ticket/reply creation by email not working among other things. This is a backwards incompatible change in Joomla 3.5 and later that we have already reported to Joomla but they decided not to revert it. Therefore we are now working around it.

Small new features:

  • Redirect to login page when a guest user tries to file a new ticket.
  • User overridable templates for the Akeeba Ticket System - Tickets info module.
  • Custom sh404SEF plugin which generates the same kind of URLs as the Joomla! SEF router.
  • Non-SEF URLs generated by ATS 1.x are now automatically mapped and work with ATS 2.x
  • Plugin to displaying the user's avatar using the EasySocial user avatar

PHP 5.4, 5.5, 5.6 or 7.0 is required

This version requires PHP 5.4.0 or later including 5.4, 5.5, 5.6 or 7.0. PHP 5.3 is no longer supported. We strongly advise you to use PHP 5.6 or 7.0. Support for older versions of PHP will be dropped in the next few months.

Joomla! 3.x up to 3.4 does NOT run on PHP 7.0. We only support using our software on PHP 7.0 with Joomla! 3.5.

Joomla! 3.4, 3.5 and 3.6 is supported

This version of our software can be installed on Joomla! 3.4.x, 3.5.x or 3.6.x. It is not compatible with end-of-life Joomla! 1.x, 2.5, or 3.0 to 3.3 releases (inclusive). If you are using an old Joomla! version please upgrade to the latest Joomla! 3 version available from Joomla.org.

Changelog

Bug fixes

  • [LOW] Canned replies in front-end do not respect the ordering (gh-164)
  • [MEDIUM] Auto-replies feature will keep replying to the ticket every time the user replies to it (gh-162)
  • [MEDIUM] The backend menu item could disappear sometimes from the Joomla components menu (gh-163)

Take me to the downloads for this version

Version 2.2.1 Stable

Released on: Tuesday, 19 July 2016 05:38

 

Maturity
Stable
Released on
Tuesday, 19 July 2016 05:38
Viewed
0 times

This release adds a few minor features and improves the overall stability of the component under Joomla! 3.5 and 3.6.

Release highlights

Work around Joomla 3.5's mailer bug (since it's not getting fixed by Joomla). If your site's Email From address in Global Configuration or your user's email address were malformed Joomla would crash when trying to send out emails. This could result in ticket/reply creation by email not working among other things. This is a bug in Joomla 3.5 itself that we have already reported to Joomla but they decided not to fix it. Therefore we are working around it.

Small new features:

  • Redirect to login page when a guest user tries to file a new ticket.
  • User overridable templates for the Akeeba Ticket System - Tickets info module.
  • Custom sh404SEF plugin which generates the same kind of URLs as the Joomla! SEF router.
  • Non-SEF URLs generated by ATS 1.x are now automatically mapped and work with ATS 2.x
  • Plugin to displaying the user's avatar using the EasySocial user avatar

PHP 5.4, 5.5, 5.6 or 7.0 is required

This version requires PHP 5.4.0 or later including 5.4, 5.5, 5.6 or 7.0. PHP 5.3 is no longer supported. We strongly advise you to use PHP 5.6 or 7.0. Support for older versions of PHP will be dropped in the next few months.

Joomla! 3.x up to 3.4 does NOT run on PHP 7.0. We only support using our software on PHP 7.0 with Joomla! 3.5.

Joomla! 3.4, 3.5 and 3.6 is supported

This version of our software can be installed on Joomla! 3.4.x, 3.5.x or 3.6.x. It is not compatible with end-of-life Joomla! 1.x, 2.5, or 3.0 to 3.3 releases (inclusive). If you are using an old Joomla! version please upgrade to the latest Joomla! 3 version available from Joomla.org.

At the time of this writing we were only able to test ATS against Joomla! 3.6 Release Candidate. The stable version is not yet released. However, we do not expect any issues with the final 3.6 stable release.

Changelog

Bug fixes

  • Post emails not sent
  • [LOW] Could not select Joomla user in backend

Take me to the downloads for this version

Version 2.2.0 Stable

Released on: Monday, 04 July 2016 03:29

 

Maturity
Stable
Released on
Monday, 04 July 2016 03:29
Viewed
0 times

This release adds a few minor features and improves the overall stability of the component under Joomla! 3.5 and 3.6.

Release highlights

Work around Joomla 3.5's mailer bug (since it's not getting fixed by Joomla). If your site's Email From address in Global Configuration or your user's email address were malformed Joomla would crash when trying to send out emails. This could result in ticket/reply creation by email not working among other things. This is a bug in Joomla 3.5 itself that we have already reported to Joomla but they decided not to fix it. Therefore we are working around it.

Small new features:

  • Redirect to login page when a guest user tries to file a new ticket.
  • User overridable templates for the Akeeba Ticket System - Tickets info module.
  • Custom sh404SEF plugin which generates the same kind of URLs as the Joomla! SEF router.
  • Non-SEF URLs generated by ATS 1.x are now automatically mapped and work with ATS 2.x
  • Plugin to displaying the user's avatar using the EasySocial user avatar

PHP 5.4, 5.5, 5.6 or 7.0 is required

This version requires PHP 5.4.0 or later including 5.4, 5.5, 5.6 or 7.0. PHP 5.3 is no longer supported. We strongly advise you to use PHP 5.6 or 7.0. Support for older versions of PHP will be dropped in the next few months.

Joomla! 3.x up to 3.4 does NOT run on PHP 7.0. We only support using our software on PHP 7.0 with Joomla! 3.5.

Joomla! 3.4, 3.5 and 3.6 is supported

This version of our software can be installed on Joomla! 3.4.x, 3.5.x or 3.6.x. It is not compatible with end-of-life Joomla! 1.x, 2.5, or 3.0 to 3.3 releases (inclusive). If you are using an old Joomla! version please upgrade to the latest Joomla! 3 version available from Joomla.org.

At the time of this writing we were only able to test ATS against Joomla! 3.6 Release Candidate. The stable version is not yet released. However, we do not expect any issues with the final 3.6 stable release.

Changelog

New features

  • Added back the custom sh404SEF plugin
  • Added support for EasySocial user avatar
  • Mapped the old front-end view names to the new ones to let your old, ATS 1.x, non-SEF URLs work properly.
  • Redirect to login page when a guest user tries to file a new ticket
  • User overridable templates for the "Akeeba Ticket System - Tickets info" module

Miscellaneous changes

  • Changing the #__akeeba_common table schema
  • Work around MAJOR BUG IN JOOMLA! 3.5 regarding email sending, only affects update notifications

Removed features

  • Removed custom Mailer, now using JMail

Take me to the downloads for this version

Version 2.1.2 Stable

Released on: Friday, 01 April 2016 03:15

 

Maturity
Stable
Released on
Friday, 01 April 2016 03:15
Viewed
0 times

This is a minor release, improving stability and compatibility with Joomla! 3.5.

Release highlights

UTF8MB4 support (requires Joomla! 3.5 and a PHP/MySQL environment with UTF8MB4 support). If you have Joomla! 3.5 and a compatible server you can use multibyte characters, e.g. Emoji, everywhere: categories, ticket titles, posts, etc.

PHP 7 and Joomla! 3.5 compatible.

PHP 5.3, 5.4, 5.5, 5.6 or 7.0 is required

This version requires PHP 5.3.10 or later, including 5.4, 5.5 or 5.6. It won't install on hosts running PHP 5.2 or earlier. PHP 5.3.10 or later is required, due to Joomla! requirements. Important note on reading PHP versions: PHP 5.3.20 is newer than 5.3.10 which is newer than 5.3.4. Moreover, PHP 5.4.0 is newer than PHP 5.3.10.

Joomla! 3.x up to 3.4 does NOT run on PHP 7.0. We only support using our software on PHP 7.0 with Joomla! 3.5.

Joomla! 3.4 and 3.5 is supported

This version of our software can be installed on Joomla! 3.4.x or 3.5.x. It is not compatible with end-of-life Joomla! 1.x, 2.5, or 3.0 to 3.3 releases (inclusive). If you are using an old Joomla! version please upgrade to the latest Joomla! 3 version available from Joomla.org.

Changelog

Bug fixes

  • [MEDIUM] Fixed backend views in systems with case-sensitive filesystem
  • [MEDIUM] Fixed filter on category access level

Take me to the downloads for this version

Version 2.1.1 Stable

Released on: Sunday, 20 March 2016 16:42

 

Maturity
Stable
Released on
Sunday, 20 March 2016 16:42
Viewed
0 times

This is a minor release, improving stability and compatibility with Joomla! 3.5.

Release highlights

UTF8MB4 support (requires Joomla! 3.5 and a PHP/MySQL environment with UTF8MB4 support). If you have Joomla! 3.5 and a compatible server you can use multibyte characters, e.g. Emoji, everywhere: categories, ticket titles, posts, etc.

PHP 7 and Joomla! 3.5 compatible.

PHP 5.3, 5.4, 5.5, 5.6 or 7.0 is required

This version requires PHP 5.3.10 or later, including 5.4, 5.5 or 5.6. It won't install on hosts running PHP 5.2 or earlier. PHP 5.3.10 or later is required, due to Joomla! requirements. Important note on reading PHP versions: PHP 5.3.20 is newer than 5.3.10 which is newer than 5.3.4. Moreover, PHP 5.4.0 is newer than PHP 5.3.10.

Joomla! 3.x up to 3.4 does NOT run on PHP 7.0. We only support using our software on PHP 7.0 with Joomla! 3.5.

Joomla! 3.4 and 3.5 is supported

This version of our software can be installed on Joomla! 3.4.x or 3.5.x. It is not compatible with end-of-life Joomla! 1.x, 2.5, or 3.0 to 3.3 releases (inclusive). If you are using an old Joomla! version please upgrade to the latest Joomla! 3 version available from Joomla.org.

Changelog

Critical bugs and important changes

  • Installation error

Take me to the downloads for this version

Version 2.1.0 Stable

Released on: Sunday, 20 March 2016 12:58

 

Maturity
Stable
Released on
Sunday, 20 March 2016 12:58
Viewed
0 times

This is a minor release, improving stability and compatibility with Joomla! 3.5.

Release highlights

UTF8MB4 support (requires Joomla! 3.5 and a PHP/MySQL environment with UTF8MB4 support). If you have Joomla! 3.5 and a compatible server you can use multibyte characters, e.g. Emoji, everywhere: categories, ticket titles, posts, etc.

PHP 7 and Joomla! 3.5 compatible.

PHP 5.3, 5.4, 5.5, 5.6 or 7.0 is required

This version requires PHP 5.3.10 or later, including 5.4, 5.5 or 5.6. It won't install on hosts running PHP 5.2 or earlier. PHP 5.3.10 or later is required, due to Joomla! requirements. Important note on reading PHP versions: PHP 5.3.20 is newer than 5.3.10 which is newer than 5.3.4. Moreover, PHP 5.4.0 is newer than PHP 5.3.10.

Joomla! 3.x up to 3.4 does NOT run on PHP 7.0. We only support using our software on PHP 7.0 with Joomla! 3.5.

Joomla! 3.4 and 3.5 is supported

This version of our software can be installed on Joomla! 3.4.x or 3.5.x. It is not compatible with end-of-life Joomla! 1.x, 2.5, or 3.0 to 3.3 releases (inclusive). If you are using an old Joomla! version please upgrade to the latest Joomla! 3 version available from Joomla.org.

Changelog

Bug fixes

  • [LOW] Display the time spent on a reply only if we're managers
  • [MEDIUM] Fixed ticket submission when time spent field is mandatory

New features

  • UTF8MB4 support for our own database tables (requires Joomla! 3.5 and a PHP/MySQL environment with UTF8MB4 support)

Miscellaneous changes

  • Make sure SpamAssassin doesn't mistakenly report emails as spam

Take me to the downloads for this version

Version 2.0.5 Stable

Released on: Monday, 08 February 2016 05:10

 

Maturity
Stable
Released on
Monday, 08 February 2016 05:10
Viewed
0 times

This is a bugfix release.

Release highlights

Option to make the Time Spent field mandatory.

PHP 7 and Joomla! 3.5 compatible.

PHP 5.3, 5.4, 5.5, 5.6 or 7.0 is required

This version requires PHP 5.3.10 or later, including 5.4, 5.5 or 5.6. It won't install on hosts running PHP 5.2 or earlier. PHP 5.3.10 or later is required, due to Joomla! requirements. Important note on reading PHP versions: PHP 5.3.20 is newer than 5.3.10 which is newer than 5.3.4. Moreover, PHP 5.4.0 is newer than PHP 5.3.10.

Joomla! 3.x up to 3.4 does NOT run on PHP 7.0 at the time of this writing. We only support using our software on PHP 7.0 with Joomla! 3.5.

Joomla! 3.4 and 3.5 is supported

This version of our software can be installed on Joomla! 3.4.x or 3.5.x. It is not compatible with end-of-life Joomla! 1.x, 2.5, or 3.0 to 3.3 releases (inclusive). If you are using an old Joomla! version please upgrade to the latest Joomla! 3 version available from Joomla.org.

Changelog

Bug fixes

  • [HIGH] Event naming collision with Akeeba Subscriptions custom field plugins
  • [LOW] Some CSS/JS files wouldn't load with the correct media versioning tag in specific front-end pages
  • [MEDIUM] Akeeba Subscriptions integration plugins are enabled by default

New features

  • Option to make the Time Spent field mandatory (thanks @compojoom)

Miscellaneous changes

  • Disable CLI script workaround necessary only under Joomla! 3.4.7 on all other versions of Joomla!

Critical bugs and important changes

  • Joomla! 3.5 breaks CLI scripts, workaround applied

Take me to the downloads for this version

Version 2.0.4 Stable

Released on: Tuesday, 22 December 2015 09:05

 

Maturity
Stable
Released on
Tuesday, 22 December 2015 09:05
Viewed
0 times

This is a bugfix release addressing a major issue regarding CLI scripts introduced by Joomla! 3.4.7 as well as other known issues.

Release highlights

Workaround for CLI scripts. Joomla! 3.4.7 introduced a major bug which made it impossible for third party CLI scripts, used in CRON jobs, to complete successfully. Unfortunately it also affected the CLI scripts of our own software. This release applies a workaround which lets the CLI scripts execute without a problem.

PHP 5.3, 5.4, 5.5 or 5.6 is required

This version requires PHP 5.3.10 or later, including 5.4, 5.5 or 5.6. It won't install on hosts running PHP 5.2 or earlier. PHP 5.3.10 or later is required, due to Joomla! requirements. Important note on reading PHP versions: PHP 5.3.20 is newer than 5.3.10 which is newer than 5.3.4. Moreover, PHP 5.4.0 is newer than PHP 5.3.10.

Joomla! 3.x does NOT run on PHP 7.0 at the time of this writing. As a result we do not support using Akeeba Ticket System on PHP 7.0 yet.

Joomla! 3.4 and 3.5 is supported

This version of our software can be installed on Joomla! 3.4.x or 3.5.x. It is not compatible with end-of-life Joomla! 1.x, 2.5, or 3.0 to 3.3 releases (inclusive). If you are using an old Joomla! version please upgrade to the latest Joomla! 3 version available from Joomla.org.

Changelog

Bug fixes

  • [HIGH] Joomla! 3.4.7 has a major bug which may prevent CLI (CRON) scripts from executing
  • [HIGH] The ats-auto-reply.php CLI script wouldn't work due to the wrong naming of a model class

Take me to the downloads for this version

Version 2.0.3 Stable

Released on: Monday, 21 December 2015 11:11

 

Maturity
Stable
Released on
Monday, 21 December 2015 11:11
Viewed
0 times

This is a bugfix release addressing known issues.

PHP 5.3, 5.4, 5.5 or 5.6 is required

This version requires PHP 5.3.4 or later, including 5.4, 5.5 or 5.6. It won't install on hosts running PHP 5.2 or earlier. PHP 5.3.4 or later is required, due to show-stopper bugs in earlier versions of PHP 5.3. Important note on reading PHP versions: PHP 5.3.20 is newer than 5.3.10 which is newer than 5.3.4. Moreover, PHP 5.4.0 is newer than PHP 5.3.4.

Joomla! 3.x does NOT run on PHP 7.0 at the time of this writing. As a result we do not support using Akeeba Ticket System on PHP 7.0 yet.

Joomla! 3.2, 3.3, 3.4 are supported

This version of our software can be installed on Joomla! 3.2.x, 3.3.x or 3.4.x release. It is not compatible with end-of-life Joomla! 2.5, 3.0 or 3.1 releases. If you are using them please upgrade to the latest Joomla! 3 release available from Joomla.org.

Changelog

Bug fixes

  • [LOW] Fixed breadcrumbs
  • [LOW] Fixed loading of last 30-days tickets graph
  • [LOW] Fixed ticket assignment for ticket created by email
  • [MEDIUM] Fixed loading of ticket credits when ticket priorities are enabled
  • [MEDIUM] Missing menu items for Pro features in Akeeba Ticket System Professional

New features

  • Added warning if Categories menu entry is missing
  • Usage of custom class for modal windows, to workaround broken templates

Take me to the downloads for this version

Version 2.0.2 Stable

Released on: Thursday, 12 November 2015 18:00

 

Maturity
Stable
Released on
Thursday, 12 November 2015 18:00
Viewed
0 times

This is a bugfix release. All our users are requested to update.

Please note that this version requires Joomla! 3.4.0 or later and PHP 5.4 or later. It will NOT work on Joomla! 2.5, 3.0, 3.1, 3.2 and 3.3 and it will NOT work on PHP 5.3 and earlier versions, including PHP 5.2, 5.1, 5.0 and all 4.x versions.

Release highlights

Rewritten on top of the FOF 3.0 framework. This release is based on our brand new FOF 3.0 framework, delivering significant performance improvements and stability.

BETA software – we need your help!

This is a BETA version. While it has been extensively tested we don't recommend our users using it on production sites without first evaluating it on a test site. You can create a test site using our free of charge Akeeba Backup Core site backup software.

We appreciate you filing bug reports until July 30th, 2015 when the beta period is scheduled to be over. We need your feedback. If any bugs you've discovered are not reported to us the chances are we are not aware of them either and they'll still be present in the stable release. Report any issues you encounter and we promise to fix them promptly, as always!

PHP 5.4.0+ and Joomla! 3.4+ is required

This version requires PHP 5.4.0+ (recommended), 5.5 or 5.6. It won't install on hosts running PHP 5.3.29 or earlier, including PHP 5.2, 5.1, 5.0 and all 4.x versions. Moreover, this release will only work on Joomla! 3.4 and later. We strongly recommend using the latest Joomla! 3.x version released by the Joomla! Project.

Changelog

Bug fixes

  • [HIGH] The Akeeba Subscriptions 4 integration plugin is enabled by default but causes a fatal error if Akeeba Subscriptions 5 is installed
  • [LOW] Akeeba Ticket System Core would display menu items for unavailable features
  • [LOW] FOF 3 would be uninstalled on package uninstallation even when there are other dependencies on it
  • [LOW] Fixed thread reloading when another user posts on the same topic
  • [LOW] In some circumstances you could have redirecting issues
  • [LOW] Notice thrown by the auto-update CLI script
  • [LOW] Ticket assignment from the user's tickets and assigned tickets pages didn't work
  • [LOW] Tickets created by email were always assigned to the user that opened it
  • [LOW] When in Categories view the link to Control Panel is not visible
  • [MEDIUM] Autoclosing tickets with the CLI script led to fatal error
  • [MEDIUM] Error shown (un)publishing a Category when the Finder plugin is enabled, but the action still succeeded
  • [MEDIUM] No versioning query parameter in CSS files led to display issues after component update

New features

  • Added option to retrieve only the plain text version when creating tickets by email
  • Show time spent per ticket and user in various front-end ticket views
  • The Credits module can now display the time spent supporting the current user

Take me to the downloads for this version

Version 2.0.1 Stable

Released on: Wednesday, 14 October 2015 11:49

 

Maturity
Stable
Released on
Wednesday, 14 October 2015 11:49
Viewed
358 times

This is a major release, just out of our Beta phase. This release is based on our new FOF 3.0 framework, delivering significant performance improvements and stability.

Finally, do note that this version requires Joomla! 3.4.0 or later and PHP 5.3.10 or later. It will NOT work on Joomla! 2.5, 3.0, 3.1, 3.2 and 3.3 and it will NOT work on PHP 5.3.09 (or 5.3.9 as it's commonly written) and earlier versions, including PHP 5.3, 5.1, 5.0 and all 4.x versions.

Release highlights

Rewritten on top of the FOF 3.0 framework. This release is based on our brand new FOF 3.0 framework, delivering significant performance improvements and stability.

BETA software – we need your help!

This is a BETA version. While it has been extensively tested we don't recommend our users using it on production sites without first evaluating it on a test site. You can create a test site using our free of charge Akeeba Backup Core site backup software.

We appreciate you filing bug reports until July 30th, 2015 when the beta period is scheduled to be over. We need your feedback. If any bugs you've discovered are not reported to us the chances are we are not aware of them either and they'll still be present in the stable release. Report any issues you encounter and we promise to fix them promptly, as always!

PHP 5.4.0+ and Joomla! 3.4+ is required

This version requires PHP 5.4.0+ (recommended), 5.5 or 5.6. It won't install on hosts running PHP 5.3.29 or earlier, including PHP 5.2, 5.1, 5.0 and all 4.x versions. Moreover, this release will only work on Joomla! 3.4 and later. We strongly recommend using the latest Joomla! 3.x version released by the Joomla! Project.

Changelog

Bug fixes

  • [HIGH] Akeeba Strapper enabled in front-end when you select back-end only
  • [HIGH] Credits were not charged
  • [HIGH] Javascript error when you disable Akeeba Strapper
  • [LOW] Auto-assign on tickets created by email was not working
  • [LOW] Backend tickets view, the Category drop down did not work
  • [LOW] Fixed ATS mail fetching while running in CLI environment
  • [LOW] Fixed ordering by time spent in backend tickets page
  • [LOW] Sorting in the back-end did not work
  • [LOW] User tags not applied when ticket is filed on behalf of a user by a manager from the front-end
  • [MEDIUM] Fixed calculation of left credits
  • [MEDIUM] Fixed loading of the graph in Time Cards page
  • [MEDIUM] Wrong update site for the Professional version

New features

  • You can now filter tickets by ID in the back-end

Take me to the downloads for this version

Version 2.0.0 Stable

Released on: Wednesday, 09 September 2015 15:21

 

Maturity
Stable
Released on
Wednesday, 09 September 2015 15:21
Viewed
410 times

This is a major release, currently in Beta phase. This release is based on our brand new FOF 3.0 framework, delivering significant performance improvements and stability.

IMPORTANT! This is a BETA version. While it has been extensively tested we don't recommend our users using it on production sites without first evaluating it on a test site. Please report any issues you discover so we can fix them before the stable release.

Finally, do note that this version requires Joomla! 3.4.0 or later and PHP 5.3.10 or later. It will NOT work on Joomla! 2.5, 3.0, 3.1, 3.2 and 3.3 and it will NOT work on PHP 5.3.09 (or 5.3.9 as it's commonly written) and earlier versions, including PHP 5.3, 5.1, 5.0 and all 4.x versions.

Release highlights

Rewritten on top of the FOF 3.0 framework. This release is based on our brand new FOF 3.0 framework, delivering significant performance improvements and stability.

BETA software – we need your help!

This is a BETA version. While it has been extensively tested we don't recommend our users using it on production sites without first evaluating it on a test site. You can create a test site using our free of charge Akeeba Backup Core site backup software.

We appreciate you filing bug reports until July 30th, 2015 when the beta period is scheduled to be over. We need your feedback. If any bugs you've discovered are not reported to us the chances are we are not aware of them either and they'll still be present in the stable release. Report any issues you encounter and we promise to fix them promptly, as always!

PHP 5.3.04+ and Joomla! 3.4+ is required

This version requires PHP 5.3.10+, 5.4 (recommended), 5.5 or 5.6. The rationale behind this is explained in our statement of mid-February 2013. It won't install on hosts running PHP 5.3.09 or earlier, including PHP 5.2, 5.1, 5.0 and all 4.x versions. Moreover, this release will only work on Joomla! 3.4 and later. We strongly recommend using the latest Joomla! 3.x version released by the Joomla! Project.

WARNING! Our support for PHP 5.3 will cease anytime before August 2015 without any prior warning, as we announced in April 2015.

Changelog

Bug fixes

  • [HIGH] Exception in Latest Tickets view when using a non-English locale
  • [HIGH] Wrong update site for the Professional version
  • [LOW] Categories not ordered correctly in the front-end
  • [LOW] Categories set to "All" not shown on multi-language sites
  • [LOW] Fixed access denied error while filtering ticket status in frontend
  • [LOW] Fixed search by user in ticket page on backend
  • [LOW] Fixed ticket by email creation when the subject contains non UTF-8 characters
  • [LOW] Fixed year detection in Auto Offline feature
  • [MEDIUM] Print view wasn't working at all

New features

  • Added flag to enable UID check while processing tickets by email

Take me to the downloads for this version

Version 2.0.0.b1 Beta

Released on: Monday, 29 June 2015 07:50

 

Maturity
Beta
Released on
Monday, 29 June 2015 07:50
Viewed
689 times

This is a major release, currently in Beta phase. This release is based on our brand new FOF 3.0 framework, delivering significant performance improvements and stability.

IMPORTANT! This is a BETA version. While it has been extensively tested we don't recommend our users using it on production sites without first evaluating it on a test site. Please report any issues you discover so we can fix them before the stable release.

Finally, do note that this version requires Joomla! 3.4.0 or later and PHP 5.3.10 or later. It will NOT work on Joomla! 2.5, 3.0, 3.1, 3.2 and 3.3 and it will NOT work on PHP 5.3.09 (or 5.3.9 as it's commonly written) and earlier versions, including PHP 5.3, 5.1, 5.0 and all 4.x versions.

Release highlights

Rewritten on top of the FOF 3.0 framework. This release is based on our brand new FOF 3.0 framework, delivering significant performance improvements and stability.

BETA software – we need your help!

This is a BETA version. While it has been extensively tested we don't recommend our users using it on production sites without first evaluating it on a test site. You can create a test site using our free of charge Akeeba Backup Core site backup software.

We appreciate you filing bug reports until July 30th, 2015 when the beta period is scheduled to be over. We need your feedback. If any bugs you've discovered are not reported to us the chances are we are not aware of them either and they'll still be present in the stable release. Report any issues you encounter and we promise to fix them promptly, as always!

PHP 5.3.04+ and Joomla! 3.4+ is required

This version requires PHP 5.3.10+, 5.4 (recommended), 5.5 or 5.6. The rationale behind this is explained in our statement of mid-February 2013. It won't install on hosts running PHP 5.3.09 or earlier, including PHP 5.2, 5.1, 5.0 and all 4.x versions. Moreover, this release will only work on Joomla! 3.4 and later. We strongly recommend using the latest Joomla! 3.x version released by the Joomla! Project.

WARNING! Our support for PHP 5.3 will cease anytime before August 2015 without any prior warning, as we announced in April 2015.

Changelog

Bug fixes

  • [HIGH] Private attachments were accessible if using the direct link
  • [LOW] Fixed permalink after post creation using AJAX replies
  • [LOW] Fixed recording of clicks when the users changes the title of ticket

Miscellaneous changes

  • New release based on FOF 3.0

Take me to the downloads for this version

Version 1.6.1 Stable

Released on: Wednesday, 25 February 2015 11:34

 

Maturity
Stable
Released on
Wednesday, 25 February 2015 11:34
Viewed
2223 times

This is a bugfix release addressing known issues.

PHP 5.3, 5.4, 5.5 or 5.6 is required

This version requires PHP 5.3, 5.4, 5.5 or 5.6. The rationale behind this is explained in our statement of mid-February 2013. It won't install on hosts running PHP 5.2 or earlier. PHP 5.3.4 or later is required, due to show-stopper bugs in earlier versions of PHP 5.3. Important note on reading PHP versions: PHP 5.3.20 is newer than 5.3.10 which is newer than 5.3.4. Moreover, PHP 5.4.0 is newer than PHP 5.3.4.

Joomla! 3.2, 3.3, 3.4 are supported

This version of our software can be installed on Joomla! 3.2.x, 3.3.x or 3.4.x release. It is not compatible with end-of-life Joomla! 2.5, 3.0 or 3.1 releases. If you are using them please upgrade to the latest Joomla! 3 release available from Joomla.org.

Changelog

Bug fixes

  • [HIGH] Cannot edit tickets in backend if the user who owns the ticket has active subscriptions and the Akeeba Subscriptions integration is enabled.
  • [LOW] Country flags were all wrong
  • [LOW] Email password in component options was displayed in plain text, not using a password field
  • [LOW] Fixed missing "Add to bucket" button in Tickets page
  • [LOW] Fixed missing "Send test email" button in Email Template page
  • [MEDIUM] Fatal error while creating a ticket from backend and the user has one or more subscriptions

Take me to the downloads for this version

Version 1.6.0 Stable

Released on: Monday, 16 February 2015 04:36

 

Maturity
Stable
Released on
Monday, 16 February 2015 04:36
Viewed
687 times

This is a features and maintenance release. All users on Joomla! 3.2 or later are kindly requested to update.

IMPORTANT! This version no longer supports Joomla! 2.5.

Release highlights

Dropped Joomla! 2.5 support. As previously announced, releases of our software after January 15th, 2015 no longer support Joomla! 2.5. Joomla! 2.5 has been end-of-life since December 31st, 2014. If you are still using it you are advised to urgently update.

Improved frontend features for support staff. An assortment of features which previously required backend access have now been added for all frontend support staff users. Clicking on a username will display a list of all tickets filed by that user. You can filter the tickets of a user or the assigned tickets by support category. The country of origin of a user will be displayed below their username (if you're using Akeeba Subscriptions and have activated the integration plugin).

Improved frontend features for clients. Clients can now filter their filed tickets ("My tickets" view) by category.

Changelog

Bug fixes

  • [LOW] Validation on custom fields linked to a specific category was not working
  • [LOW] gh-117 Wrong signature and subscription list for System Task (automatically closed tickets notification post)
  • [LOW] gh-120 Fixed attachment name in notification emails
  • [LOW] gh-126 Email notification not sent when creating a ticket on behalf of a user

New features

  • Check for obsolete PHP versions and printing a warning
  • Display all tickets created by a specific user
  • Display customer country flag accordingly to the data stored inside Akeeba Subscriptions

Miscellaneous changes

  • gh-116 Remove deprecated assign / assignRef from all views (code quality)

Removed features

  • Removed Joomla! 2.5 support

Take me to the downloads for this version

Version 1.5.5 Stable

Released on: Wednesday, 26 November 2014 03:43

 

Maturity
Stable
Released on
Wednesday, 26 November 2014 03:43
Viewed
1745 times

This is a minor release, fixing known issues.

PHP 5.3, 5.4, 5.5 or 5.6 is required

This version requires PHP 5.3, 5.4, 5.5 or 5.6. The rationale behind this is explained in our statement of mid-February 2013. It won't install on hosts running PHP 5.2 or earlier. PHP 5.3.4 or later is required, due to show-stopper bugs in earlier versions of PHP 5.3. Important note on reading PHP versions: PHP 5.3.20 is newer than 5.3.10 which is newer than 5.3.4. Moreover, PHP 5.4.0 is newer than PHP 5.3.4.

Due to the necessary Joomla! API changes found only in Joomla! 2.5.6 or later, this version will not install on Joomla! 2.5.5 or earlier versions. In any case, if your server doesn't meet the minimum requirements it will tell you exactly why it cannot be installed (minimum PHP or Joomla! version not satisfied).

Joomla! 2.5, 3.2, 3.3, 3.4 are supported

This version of our software can be installed on Joomla! 2.5.6 or any later 2.5.x release, as well as any 3.2.x, 3.3.x or 3.4.x release. It is not compatible with Joomla! 3.0 or 3.1. These versions of Joomla! are old and vulnerable. If you are using them please upgrade to the latest Joomla! 3 release available from Joomla.org.

Changelog

Bug fixes

  • [HIGH] Blank page viewing a ticket closed by System when you have thousands of active subscriptions in Akeeba Subscriptions
  • [LOW] Alphauser integration not working due to a typo
  • [LOW] Category managers couldn't create tickets on user behalf
  • [LOW] Fixed pagination issues
  • [LOW] Fixed posting ticket replies to buckets
  • [MEDIUM] Exception thrown in Latest Open view while using a language different than the English one

Miscellaneous changes

  • Changed the .htaccess files to be compatible with Apache 2.4
  • Do not limit support staff's ability to post based on credits. There are still some cases where this doesn't work properly. It requires deep refactoring which is scheduled for version 2.0.
  • Some servers seem to try and load the AkeebaUsagestats class twice

Take me to the downloads for this version

Version 1.5.4 Stable

Released on: Wednesday, 10 September 2014 01:58

 

Maturity
Stable
Released on
Wednesday, 10 September 2014 01:58
Viewed
1737 times

This is a minor release, fixing known issues.

PHP 5.3, 5.4, 5.5 or 5.6 is required

This version requires PHP 5.3, 5.4, 5.5 or 5.6. The rationale behind this is explained in our statement of mid-February 2013. It won't install on hosts running PHP 5.2 or earlier. PHP 5.3.4 or later is required, due to show-stopper bugs in earlier versions of PHP 5.3. Important note on reading PHP versions: PHP 5.3.20 is newer than 5.3.10 which is newer than 5.3.4. Moreover, PHP 5.4.0 is newer than PHP 5.3.4.

Due to the necessary Joomla! API changes found only in Joomla! 2.5.6 or later, this version will not install on Joomla! 2.5.5 or earlier versions. In any case, if your server doesn't meet the minimum requirements it will tell you exactly why it cannot be installed (minimum PHP or Joomla! version not satisfied).

Joomla! 2.5, 3.2, 3.3, 3.4 are supported

This version of our software can be installed on Joomla! 2.5.6 or any later 2.5.x release, as well as any 3.2.x, 3.3.x or 3.4.x release. It is not compatible with Joomla! 3.0 or 3.1. These versions of Joomla! are old and vulnerable. If you are using them please upgrade to the latest Joomla! 3 release available from Joomla.org.

Changelog

Bug fixes

  • [LOW] "COM_ATS_ERR_MAIL_CANNOTRETRIEVE Mailbox is empty" shown when there are no new ticket emails to retrieve
  • [LOW] HTTP 403 when creating a new ticket due to the call to view=attempts
  • [LOW] gh-93 Display ticket times using site timezone
  • [LOW] gh-96 Fatal error in ticket removal CRON script when used on a Joomla! 2.5 site
  • [LOW] gh-97 Filter status on frontend bucket list was not working
  • [LOW] gh-98 In some conditions enabling Joomla SEF will produce 404 pages
  • [MEDIUM] Joomla! caches plugin information, leading to unexpected behaviour in various places
  • [MEDIUM] gh-95 Managers couldn't access to buckets list on frontend

New features

  • "Latest Tickets" view: display how long ago the customer last replied to the ticket
  • Display list of accepted attachment extensions

Miscellaneous changes

  • Even better workaround for very badly written system plugins which output Javascript without a trailing semicolon and/or newline, leading to Javascript errors. This is not a bug in our software, it's a bug in those badly written plugins and WE have to work around THEIR bad code!

Take me to the downloads for this version

Version 1.5.3 Stable

Released on: Thursday, 17 July 2014 11:27

 

Maturity
Stable
Released on
Thursday, 17 July 2014 11:27
Viewed
1409 times

This is a maintenance release, fixing mostly issues with the email-related features of Akeeba Ticket System.

PHP 5.3, 5.4 or 5.5 is required

This version requires PHP 5.3, 5.4 or 5.5. The rationale behind this is explained in our statement of mid-February 2013. It won't install on hosts running PHP 5.2 or earlier. PHP 5.3.4 or later is required, due to show-stopper bugs in earlier versions of PHP 5.3. Moreover, due to the necessary Joomla! API changes found only in Joomla! 2.5.6 or later, this version will not install on Joomla! 2.5.5 or earlier versions. In any case, it will tell you exactly why it cannot be installed (minimum PHP or Joomla! version not satisfied).

Joomla! 2.5, 3.2, 3.3 are supported

This version of our software can be installed on Joomla! 2.5.6 or any later 2.5.x release, as well as any 3.2.x or 3.3.x release. It is not compatible with Joomla! 3.0 or 3.1. These versions of Joomla! are old and vulnerable. If you are using them please upgrade to the latest Joomla! 3 release available from Joomla.org.

Changelog

Bug fixes

  • [HIGH] Sending new tickets by email would always result in an error
  • [HIGH] Wrong From email address when a ticket is created / replied to via email and you're using the CLI script to fetch emails
  • [LOW] Unpublished manager notes cannot be viewed or unpublished in the back-end
  • [LOW] Working around notices thrown by Joomla! core code with missing safeguards in the CLI scripts under some circumstances
  • [MEDIUM] Canned replies not shown when the logged in user has support staff privileges for a category but no component-wide support staff / admin privileges
  • [MEDIUM] Wrong email subject when a ticket reply is received by email

New features

  • Automatic update / update notification emails CLI script
  • Support for attachments made by Apple Mail in reply by email / new ticket by email features

Take me to the downloads for this version

Version 1.5.2 Stable

Released on: Thursday, 12 June 2014 01:58

 

Maturity
Stable
Released on
Thursday, 12 June 2014 01:58
Viewed
1331 times

This is a bugfix release, fixing minor issues with the previous stable release. We recommend all of our users to upgrade.

PHP 5.3, 5.4 or 5.5 is required

This version requires PHP 5.3, 5.4 or 5.5. The rationale behind this is explained in our statement of mid-February 2013. It won't install on hosts running PHP 5.2 or earlier. PHP 5.3.4 or later is required, due to show-stopper bugs in earlier versions of PHP 5.3. Moreover, due to the necessary Joomla! API changes found only in Joomla! 2.5.6 or later, this version will not install on Joomla! 2.5.5 or earlier versions. In any case, it will tell you exactly why it cannot be installed (minimum PHP or Joomla! version not satisfied).

Joomla! 2.5, 3.2, 3.3 are supported

This version of our software can be installed on Joomla! 2.5.6 or any later 2.5.x release, as well as any 3.2.x or 3.3.x release. It is not compatible with Joomla! 3.0 or 3.1. These versions of Joomla! are old and vulnerable. If you are using them please upgrade to the latest Joomla! 3 release available from Joomla.org.

Changelog

Critical bugs and important changes

  • The module to display ticket stats in the front-end throws a fatal error

Take me to the downloads for this version

Version 1.5.1 Stable

Released on: Tuesday, 10 June 2014 04:09

 

Maturity
Stable
Released on
Tuesday, 10 June 2014 04:09
Viewed
679 times

This is a bugfix release, fixing minor issues with the previous stable release. We recommend all of our users to upgrade.

PHP 5.3, 5.4 or 5.5 is required

This version requires PHP 5.3, 5.4 or 5.5. The rationale behind this is explained in our statement of mid-February 2013. It won't install on hosts running PHP 5.2 or earlier. PHP 5.3.4 or later is required, due to show-stopper bugs in earlier versions of PHP 5.3. Moreover, due to the necessary Joomla! API changes found only in Joomla! 2.5.6 or later, this version will not install on Joomla! 2.5.5 or earlier versions. In any case, it will tell you exactly why it cannot be installed (minimum PHP or Joomla! version not satisfied).

Joomla! 2.5, 3.2, 3.3 are supported

This version of our software can be installed on Joomla! 2.5.6 or any later 2.5.x release, as well as any 3.2.x or 3.3.x release. It is not compatible with Joomla! 3.0 or 3.1. These versions of Joomla! are old and vulnerable. If you are using them please upgrade to the latest Joomla! 3 release available from Joomla.org.

Changelog

Bug fixes

  • [HIGH] gh-85 email fetch should stop if the user is not registered

New features

  • Added front-end module which displays the number of open/pending/closed tickets and a link to the My Tickets page

Miscellaneous changes

  • Replacing legacy mooTools code with jQuery
  • Updated the included HTML Purifier to 4.6.0

Critical bugs and important changes

  • CLI scripts were not being copied over

Take me to the downloads for this version

Version 1.5.0 Stable

Released on: Tuesday, 06 May 2014 03:47

 

Maturity
Stable
Released on
Tuesday, 06 May 2014 03:47
Viewed
1241 times

This is a stability release. We recommend all of our users to upgrade.

IMPORTANT! This version requires PHP 5.3.5+, 5.4 (recommended) or 5.5 and Joomla! 2.5.6+, 3.2.1+ or 3.3.

Release highlights

A better, more stable way to install and update the database tables. Previous versions were using the database installation and update code in Joomla! itself which was notoriously buggy and resulted in erratic behaviour. In this release we use our own database installer / updater for the base tables of our component. Unfortunately, due to the rules in the Joomla! Extensions Directory, we still have to rely on Joomla!'s code for the administrator menu item creation which may cause no menu item appearing under components on very few sites. We are aware of it, we know how to fix it, but we are not allowed to on penalty of being permanently banned from the directory!

Show the update information in the control panel page. In the previous version we introduced the integration with Joomla!'s own extensions updater. Unfortunately you could no longer see the update information in the component's control panel page. This version fixes it and allows you to force-reload the update information if you need to as Joomla! no longer lets you do that in the latest 3.x versions (for no good reason, really).

Changelog

Bug fixes

  • [HIGH] Accessing the component fails on Joomla! 3.2.x if the core database has not been updated
  • [HIGH] SQL errors when submitting a ticket with an invalid attachment
  • [LOW] Harmless but annoying error message when no email templates are published
  • [LOW] The category labels in the spared tickets graph overlap each other

New features

  • Allow the user to forcibly refresh the update information from the component's control panel page
  • Database table installation, uninstallation and update is now handled by our own code instead of the unreliable JInstaller code
  • Show the update information in the component's control panel page

Take me to the downloads for this version

Version 1.4.1 Stable

Released on: Monday, 10 March 2014 12:28

 

Maturity
Stable
Released on
Monday, 10 March 2014 12:28
Viewed
1905 times

This is a bugfix release, fixing high priority issues with the attachments. We recommend all of our users to upgrade.

IMPORTANT! This version requires PHP 5.3.5+, 5.4 (recommended) or 5.5 and Joomla! 2.5.6+ or 3.2.

PHP 5.3, 5.4 or 5.5 is required

This version requires PHP 5.3.5+, 5.4 (recommended) or 5.5. The rationale behind this is explained in our statement of mid-February 2013. It won't install on hosts running PHP 5.2 or earlier. Moreover, due to the necessary Joomla! API changes found only in Joomla! 2.5.6 or later, this version will not install on Joomla! 2.5.5 or earlier versions. In any case, it will tell you exactly why it cannot be installed (minimum PHP or Joomla! version not satisfied).

Changelog

Bug fixes

  • [HIGH] Attachments are never shown when the private attachments option is selected
  • [HIGH] Attachments by support staff are not shown to the ticket owner when the private attachments option is selected
  • [LOW] Attachments header shown even when there are no attachment visible by the current user
  • [LOW] Prevent displaying the "Attachment" header if there are no attachments
  • [LOW] When an attachment upload fails the reason is not shown when using the AJAX reply method
  • [MEDIUM] Blank page or 400 error message after updating from 2.3.2 or lower using Live Update

Critical bugs and important changes

  • You can see public tickets in access-restricted categories if you know the ticket ID

Take me to the downloads for this version

Version 1.4.0 Stable

Released on: Sunday, 09 March 2014 13:43

 

Maturity
Stable
Released on
Sunday, 09 March 2014 13:43
Viewed
879 times

This is a maintenance release, introducing minor new features and fixing some known issues. We recommend all of our users to upgrade.

IMPORTANT! This version requires PHP 5.3.5+, 5.4 (recommended) or 5.5 and Joomla! 2.5.6+ or 3.2.

PHP 5.3, 5.4 or 5.5 is required

This version requires PHP 5.3.5+, 5.4 (recommended) or 5.5. The rationale behind this is explained in our statement of mid-February 2013. It won't install on hosts running PHP 5.2 or earlier. Moreover, due to the necessary Joomla! API changes found only in Joomla! 2.5.6 or later, this version will not install on Joomla! 2.5.5 or earlier versions. In any case, it will tell you exactly why it cannot be installed (minimum PHP or Joomla! version not satisfied).

Changelog

Bug fixes

  • [HIGH] Creating tickets by email was working erratically
  • [HIGH] Fixed error in frontend bucket view
  • [LOW] Radio box custom fields always showed a "- Select -" item despite your configuration
  • [LOW] The ats-auto-reply.php CLI script was not being installed
  • [LOW] When another user posts while you are replying you can't submit your reply without reloading the page

New features

  • InstantReply now shows suggestions from existing public tickets, not just DocImport categories
  • gh-61 Added sh404SEF plugin to create SEF url with that component

Miscellaneous changes

  • Now using the built-in Joomla! extensions updater instead of Live Update to deliver updates

Critical bugs and important changes

  • Installation errors for the Core release

Take me to the downloads for this version

Version 1.3.2 Stable

Released on: Saturday, 04 January 2014 04:07

 

Maturity
Stable
Released on
Saturday, 04 January 2014 04:07
Viewed
2762 times

This is a maintenance release, introducing new features and fixing known issues. We recommend all of our users to upgrade. If you have trouble upgrading, please consult our troubleshooting instructions for February 2013 releases page.

IMPORTANT! This version requires PHP 5.3.5+ or 5.4 (recommended) and Joomla! 2.5.6+ or 3.2.

General information

If you have a problem after or before installing the component please read our troubleshooting page for the February 2013 releases of our components. Do note that these issues are only likely to affect users with old versions of PHP, Joomla! and/or very old versions of our components.

Release highlights

Social "like" feature. By enabling the optional plugin your visitors can "like" and share your public tickets on social networks.

User tagging. Allows you to attach tags to users, visible only to your support staff. Very useful to mark users which require handling by a specific person or have known peculiarities in their account / setup which warrant a different treatment (e.g. people with customised installations, big client, etc).

Auto reply bot. Send automated replies to your users based on the support category, keywords in the ticket title / body, whether a human already replied, how much time has elapsed since the last reply, how many posts the user has already made in the ticket and whether there is an attachment.

Preview feature, allows you to preview the post before submitting it.

You can now add attachments using the "reply by email" and "new ticket by email" features.

PHP 5.3 or 5.4 is required

This version requires PHP 5.3.5+ or 5.4 (recommended). The rationale behind this is explained in our statement of mid-February 2013. It won't install on hosts running PHP 5.2 or earlier. Moreover, due to the necessary Joomla! API changes found only in Joomla! 2.5.6 or later, this version will not install on Joomla! 2.5.5 or earlier versions. In any case, it will tell you exactly why it cannot be installed (minimum PHP or Joomla! version not satisfied).

Changelog

Bug fixes

  • [LOW] CTRL-V/CMD-V used for the Preview feature conflicts with the Paste keybaord shortcut. Now using CTRL-P/CMD-V instead.

Critical bugs and important changes

  • The installation script throws a SQL error if the #__ats_usertags table already exists

Take me to the downloads for this version

Version 1.3.1 Stable

Released on: Friday, 27 December 2013 10:20

 

Maturity
Stable
Released on
Friday, 27 December 2013 10:20
Viewed
1189 times

This is a maintenance release, introducing new features and fixing known issues. We recommend all of our users to upgrade. If you have trouble upgrading, please consult our troubleshooting instructions for February 2013 releases page.

IMPORTANT! This version requires PHP 5.3.5+ or 5.4 (recommended) and Joomla! 2.5.6+ or 3.2.

General information

If you have a problem after or before installing the component please read our troubleshooting page for the February 2013 releases of our components. Do note that these issues are only likely to affect users with old versions of PHP, Joomla! and/or very old versions of our components.

Release highlights

Social "like" feature. By enabling the optional plugin your visitors can "like" and share your public tickets on social networks.

User tagging. Allows you to attach tags to users, visible only to your support staff. Very useful to mark users which require handling by a specific person or have known peculiarities in their account / setup which warrant a different treatment (e.g. people with customised installations, big client, etc).

Auto reply bot. Send automated replies to your users based on the support category, keywords in the ticket title / body, whether a human already replied, how much time has elapsed since the last reply, how many posts the user has already made in the ticket and whether there is an attachment.

Preview feature, allows you to preview the post before submitting it.

You can now add attachments using the "reply by email" and "new ticket by email" features.

PHP 5.3 or 5.4 is required

This version requires PHP 5.3.5+ or 5.4 (recommended). The rationale behind this is explained in our statement of mid-February 2013. It won't install on hosts running PHP 5.2 or earlier. Moreover, due to the necessary Joomla! API changes found only in Joomla! 2.5.6 or later, this version will not install on Joomla! 2.5.5 or earlier versions. In any case, it will tell you exactly why it cannot be installed (minimum PHP or Joomla! version not satisfied).

Changelog

Bug fixes

  • [HIGH] Javascript was broken in some areas of the front-end in Joomla! 2.5
  • [HIGH] Notification emails were sent to all managers in a category, not just the selected ones.
  • [HIGH] The CRON job for the reply by email feature would return "Application Instantiation Error" under Joomla! 3.x
  • [LOW] Off-line schedule settings were not saved
  • [LOW] Untranslated string COM_ATS_LBL_OFFLINESCHEDULE_SAVED after saving Off-line schedule settings
  • [MEDIUM] When the ticket system is off-line users are shown a message about not having enough credits instead of the off-line message.

New features

  • Auto reply bot. Send automatic replies to tickets based on preset criteria.
  • Preview feature allows you to preview the post before submitting it
  • Social "like" feature: visitors can "like" and share your public tickets on social networks
  • User tagging. Tag users, visible only to the support staff.
  • You can now add attachments using the "reply by email" and "new ticket by email" features

Miscellaneous changes

  • Renamed SQL updates folder from "update" to "updates"

Take me to the downloads for this version

Version 1.3.0 Stable

Released on: Thursday, 21 November 2013 08:11

 

Maturity
Stable
Released on
Thursday, 21 November 2013 08:11
Viewed
1825 times

This is a features release, introducing new features and fixing known issues. We recommend all of our users to upgrade. If you have trouble upgrading, please consult our troubleshooting instructions for February 2013 releases page.

IMPORTANT! This version requires PHP 5.3.5+ or 5.4 (recommended) and Joomla! 2.5.6+ or 3.2.

General information

If you have a problem after or before installing the component please read our troubleshooting page for the February 2013 releases of our components. Do note that these issues are only likely to affect users with old versions of PHP, Joomla! and/or very old versions of our components.

Release highlights

AJAX replies. This is something you may have seen on other sites, such as GitHub. When you type a reply it is instantly submitted and displayed on your screen without the need to reload the entire page. This new feature is enabled by default.

Canned replies and latest open tickets are now keyboard-aware. Select the item you want with the j/k keys, select it with ENTER. Useful for keyboard junkies – we know most developers will appreciate this!

Various display tweaks: the time spent per reply and in total on the ticket is shown in the front-end; a print view for tickets (visible only to managers); fitlers in the My Tickets view in the front-end; improved back-end layout for Joomla! 3.x.

You can now set multiple tickets as public / private from the back-end of the component. Useful if you have a handful of users who screwed up posting their tickets (yes, we know how often that happens).

There's a new custom field type, text area. This is useful for gathering information that normally doesn't fit into the main ticket text.

PHP 5.3 is required

This version requires PHP 5.3.5+ or 5.4 (recommended). The rationale behind this is explained in our statement of mid-February 2013. It won't install on hosts running PHP 5.2 or earlier. Moreover, due to the necessary Joomla! API changes found only in Joomla! 2.5.6 or later, this version will not install on Joomla! 2.5.5 or earlier versions. In any case, it will tell you exactly why it cannot be installed (minimum PHP or Joomla! version not satisfied).

Changelog

Bug fixes

  • [LOW] Ampersands, lower than and greater than signs appear incorrectly when using the BBcode [code] tag
  • [LOW] The Time column in the Tickets view was always blank
  • [LOW] The status selection dropdown in the front-end tickets page didn't have any effect
  • [LOW] You could not set the Enabled status of a custom field when creating it
  • [MEDIUM] If the ticket assignment changed, the time spent would be credited to the last assignee, not the support staff who had put in the time

New features

  • AJAX-powered ticket reply feature (enabled by default). A much faster way for your users and support staff to reply to tickets from the web.
  • Canned replies are now keyboard aware: select a canned reply with the j and k keys, expand it with the + key and use it pressing the ENTER key
  • Filters in the My Tickets view
  • Latest open tickets are now keyboard aware: select a ticket in the Latest Open page with the j and k keys, open it by pressing the ENTER key
  • Print view for tickets. Come in handy when a client requests a printout of the ticket to show to their boss. Note: only managers can see the print view; your clients will have to request you to provide a printout, they can't produce it themselves.
  • Text area custom field type with customisable row and column count
  • The time spent per reply is shown in the front-end
  • The total time spent and total amount of credits charged per ticket is shown in the front-end
  • You can now set multiple tickets as public / private from the back-end of the component

Miscellaneous changes

  • Improved back-end layout on Joomla! 3.x

Take me to the downloads for this version

Version 1.2.4 Stable

Released on: Monday, 30 September 2013 06:48

 

Maturity
Stable
Released on
Monday, 30 September 2013 06:48
Viewed
2214 times

This is a maintenance and bugfix release. We recommend all of our users to upgrade. If you have trouble upgrading, please consult our troubleshooting instructions for February 2013 releases page.

IMPORTANT! This version requires PHP 5.3 or 5.4 and Joomla! 2.5.6+, 3.1 or 3.2.

General information

If you have a problem after or before installing the component please read our troubleshooting page for the February 2013 releases of our components. Do note that these issues are only likely to affect users with old versions of PHP, Joomla! and/or very old versions of our components.

PHP 5.3 is required

This version requires PHP 5.3 or 5.4. The rationale behind this is explained in our statement of mid-February 2013. It won't install on hosts running PHP 5.2 or earlier. Moreover, due to the necessary Joomla! API changes found only in Joomla! 2.5.6 or later, this version will not install on Joomla! 2.5.5 or earlier versions. In any case, it will tell you exactly why it cannot be installed (minimum PHP or Joomla! version not satisfied).

Changelog

Bug fixes

  • [HIGH] Database error during installation on some versions of MySQL
  • [LOW] You were charged credits for tickets not created when the attachment failed to upload / wasn't supported
  • [MEDIUM] You could not reply to tickets from the back-end when you used the Edit toolbar button instead of clicking on the ticket's title

New features

  • Explain the 1-5 rating when closing a ticket

Take me to the downloads for this version

Version 1.1.1 Stable

Released on: Friday, 17 May 2013 09:50

 

Maturity
Stable
Released on
Friday, 17 May 2013 09:50
Viewed
2298 times

IMPORTANT! This version requires PHP 5.3 or later and Joomla! 2.5.6 or later. It won't install on PHP 5.2 or earlier, or Joomla! 2.5.0 up to and including 2.5.5. This version is compatible with Joomla! 2.5.6+ as well as Joomla! 3.0. Please read the release notes.

This is a hotfix release, addressing known issues in the previous version which could prevent users from installing or upgrading the component. We recommend that all of our users upgrade. If you have trouble upgrading, please consult our troubleshooting instructions for February 2013 releases page.

General information

If you have a problem after or before installing the component please read our troubleshooting page for the February 2013 releases of our components. Do note that these issues are only likely to affect users with old versions of PHP, Joomla! and/or very old versions of our components.

PHP 5.3 is now required

This version requires PHP 5.3 or later. The rationale behind this is explained in our statement of mid-February 2013. It won't install on hosts running PHP 5.2 or earlier. Moreover, due to the necessary Joomla! API changes found only in Joomla! 2.5.6 or later, this version will not install on Joomla! 2.5.5 or earlier versions. In any case, it will tell you exactly why it cannot be installed (minimum PHP or Joomla! version not satisfied).

Changelog

New features

  • Show the user's real (full) name to administrators in the front-end

Miscellaneous changes

  • Better layout for the assignment label in the front-end

Bug fixes

  • [HIGH] Installation error on Joomla! 3 if the (otherwise optional) Alpha User Points component wasn't installed
  • [HIGH] My Tickets view was not working
  • [HIGH] Staff assignment per ticket wouldn't work in the front-end ticket view
  • [HIGH] Staff assignment per ticket wouldn't work in the front-end tickets list in Joomla! 2.5
  • [HIGH] Ticket view was broken in Joomla! 3
  • [HIGH] Users could not edit their posts unless they were given the core.edit.own privilege

Take me to the downloads for this version

Version 1.0.2 Stable

Released on: Thursday, 14 March 2013 08:19

 

Maturity
Stable
Released on
Thursday, 14 March 2013 08:19
Viewed
2875 times

IMPORTANT! This version requires PHP 5.3 or later and Joomla! 2.5.6 or later. It won't install on PHP 5.2 or earlier, or Joomla! 2.5.0 up to and including 2.5.5. This version is compatible with Joomla! 2.5.6+ as well as Joomla! 3.0. Please read the release notes.

This is a bugfix and maintenance release, addressing known issues in the previous version and adding new features. We recommend that all of our users upgrade. If you have trouble upgrading, please consult our troubleshooting instructions for February 2013 releases page.

General information

If you have a problem after or before installing the component please read our troubleshooting page for the February 2013 releases of our components. Do note that these issues are only likely to affect users with old versions of PHP, Joomla! and/or very old versions of our components.

PHP 5.3 is now required

This version requires PHP 5.3 or later. The rationale behind this is explained in our statement of mid-February 2013. It won't install on hosts running PHP 5.2 or earlier. Moreover, due to the necessary Joomla! API changes found only in Joomla! 2.5.6 or later, this version will not install on Joomla! 2.5.5 or earlier versions. In any case, it will tell you exactly why it cannot be installed (minimum PHP or Joomla! version not satisfied).

Changelog

New features

  • "Latest Open" view, shows the open tickets across all categories in the front-end
  • "Support Staff" privilege for individual categories, allowing you to create users which can manage only one specific category
  • Option to have a category default to Private tickets (default: create Public tickets unless the user specifies otherwise)
  • Scheduled off-line, allows you to set the ticket system off-line for new tickets and/or replies based on a schedule
  • Warn users when their Download ID is missing

Miscellaneous changes

  • Better language handling in the front-end when not using SEF URLs
  • Reduced key size in the #__ats_credittransactions table to cater for older versions of MySQL

Bug fixes

  • [HIGH] Internal server error on ancient versions of PHP 5.3 with broken late static binding implementations
  • [LOW] Canonical URL redirection causing problems when SEF is disabled
  • [LOW] Double post button on IE8
  • [LOW] Missing quote from categories model could cause no categories to be shown in the front-end
  • [MEDIUM] You could not create menu items pointing to specific categories

Take me to the downloads for this version

Releases per page: