Announcements

Admin Tools 4.0 beta – please help!

Admin Tools 4.0 has been rewritten from scratch. We need your help testing it before its stable release.

In the interest of moving our software forward and keep up with the times, we have rewritten Admin Tools from scratch using our advanced FOF 3.0 framework. Like every other Admin Tools release it has undergone extensive automated testing against all supported PHP and Joomla versions and found to be working fine. However, no amount of testing is as good as the real thing, i.e. running it on actual sites with all the, um, "creatively" configured servers out there. For this reason we have published a beta (testing) version we are asking you to use –and abuse– on your sites. If you bump into a bug please let us know.

Joomla and PHP compatibility changes

Admin Tools 4.0 has higher minimum requirements than its predecessor.

You need Joomla! 3.3, 3.4, 3.5 or 3.6* to install it. Joomla! 1.x, 2.x, 3.0, 3.1 and 3.2 are not supported. Furthermore, we recommend always using the latest published stable Joomla version for security reasons. 

You will also need PHP 5.4, 5.5, 5.6 or 7.0. We no longer support PHP 5.3. We strongly recommend using only PHP 5.6 or 7.0 on your site for security reasons. Please note that PHP 5.3 to 5.5 are or are soon to be End of Life per PHP's official End of Life versions page and official current versions page. PHP versions which are end of life have stopped receiving security updates. Even if your host's Linux distribution claims to backport security fixes please note that this only applies to Important and Critical items. Lower importance security issues remain unpatched but can just as well be used to hack your server. Major Joomla components are already dropping support for EOL versions and Joomla itself is currently discussing raising the minimum requirements to PHP 5.6 or 7.0 in the next few months. Stay safe, update your PHP version. Bonus points: PHP 5.6 and 7.0 are impressively faster (2x to 3x) than PHP 5.3. By upgrading your PHP version your site will load faster and you'll get better search engine rankings. Sweet!

* Admin Tools was tested against Joomla! 3.6.0 beta 1 and beta 2. These are the only available Joomla 3.6 versions at the time of this writing. We cannot guarantee the compatibility of Admin Tools 4.0.0.b1 with later Joomla 3.6 versions. In case Joomla 3.6 is not compatible with our software we'll of course release a new version to address that!

Known issues

You cannot use Admin Tools if you have eAccelerator installed (eAccelerator is broken and discontinued). eAccelerator was a PHP code cache, designed to speed up the execution of your PHP scripts. However, it stopped being developed in 2012 before PHP 5.4.0 was released. It is not compatible with PHP 5.4 and later and, in fact, it causes perfectly working code to fail. Using it is insecure and misguided. If you are on such a host we will show you a Big Fat Warning when you try to run Admin Tools and refuse to do anything further. Simply put, eAccelerator is dead. Stop trying to use it, it only breaks your sites! PHP 5.5 and later come with a fantastic and free alternative, Zend Opcache, which is built right into PHP and written by the people who write the PHP engine itself. Do yourself a favor and use it instead of eAccelerator.

How to install the beta releases (they're really stable!)

We consider the 4.0.0.b1 (beta) release to actually be stable enough to be used on live sites. Please use it and do report any issues you may encounter on Twitter or through our contact form. While we can't promise to reply to each one of you personally do rest assured that we do read all of your contact requests and act on them.

If you already have Admin Tools 3.8.5 installed on your site you can update to the beta release 4.0.0.b1 automatically. You just need to tell Joomla to let you install beta release by following the instructions below:

  1. Go to Extensions, then Manage, then Update from the administrator menu.
  2. Click on ‘Options’ in the top-right corner.
  3. Change the “Minimum Stability” to “Beta”
  4. Save and Close.
  5. Click on “Clear Cache”
  6. Click on “Find Updates”
  7. Select Admin Tools, and click “Update” in the top left.
  8. Use normally, and please report bugs as soon as possible!

IMPORTANT! If you get inexplicable errors immediately upon launching Admin Tools or other weird behavior please follow the manual installation instructions below. About 5% of Joomla sites are affected by a notorious Joomla bug which sometimes causes a problem when updating to a new version of a component that has a different folder structure, causing Joomla to forget to copy new files or remove old ones. We have been trying to track it down since 2007 but the darned thing is still elusive. The only tested and tried workaround we know of is the double manual installation we describe below.

If you are using an older version of Admin Tools you can update to the beta release 4.0.0.b1 manually. Just download it from our Download page and install it twice in a row, without uninstalling Admin Tools before or in between.