Support

Akeeba Backup for Joomla!

#28835 – Akeeba Backup (and Admintools) are not working with PHP 7.2.0

Posted in ‘Akeeba Backup for Joomla!’
This is a public ticket. Everybody will be able to see its contents. Do not include usernames, passwords or any other sensitive information.
Wednesday, 06 December 2017 13:49 CST
Description of my issue:
Hi, i test a little bit on my Joomla Testsite with Akeeba Backup and AdminTools and PHP 7.2.0.
When i open the extension in the Backend, i get an Error (on both extensions)
HTTP ERROR 500
If you need access to my test joomla, please let me know.

WBR,
deltapapa
Custom Fields
Joomla! version (in x.y.z format)
3.8.2
PHP version (in x.y.z format)
7.2.0
Akeeba Backup version (x.y.z format)
5.6.0
Edited by deltapapa on 2017-12-06 19:49
Thursday, 07 December 2017 00:23 CST
There is a known issue with your current version of Akeeba Backup and Admin Tools. One of the internal classes has the name Object. This is incompatible with PHP 7.2. We have fixed it over a month ago but there is no released version including this fix yet. The primary reason for that is Joomla! 4 and our mad dash to make our software compatible with it, depriving us from any resources to do anything else at all.

I'd like to point out that PHP 7.2 went stable just days ago. Moreover, this version of the PHP language introduces a lot of significant changes in the language which can affect how existing code works. While we do test our software against new PHP versions -we actually tested Akeeba Backup against PHP 7.2 since the first alpha of PHP 7.2- not all developers do. Even though we will address the issues with a new release it might take months for all Joomla! software to get up to speed with PHP 7.2. For this reason I would very strongly recommend staying on PHP 7.1 for another two months.




Nicholas K. Dionysopoulos


Lead Developer and Director






Greek: native


English: excellent


French: basic






Please keep in mind my timezone and cultural differences when reading my replies. Thank you!






Saturday, 06 January 2018 17:17 CST
This ticket has been automatically closed. All tickets which have been inactive for a long time are automatically closed. If you believe that this ticket was closed in error, please contact us.
Edited by on 2018-01-06 23:17
This ticket is closed, therefore read-only. You can no longer reply to it. If you need to provide more information, please open a new ticket and mention this ticket's number.

Support Information

Unavailability: Our company will be closed December 22nd, 2017 19:00 EET to December 28th, 2017 09:00 EET due to Christmas holidays. Furthermore, we will be closed December 29th, 2017 19:00 EET to January 3rd, 2018 09:00 EET due to New Year's holidays. During that time our support will be closed for new tickets and replies. Thank you for your understanding and Happy Holidays!

Working hours: Typically we work Monday to Friday, 9am to 7pm Cyprus timezone (EEST). Support is provided by the same developers writing the software, all of which live in Europe. We cannot respond to tickets outside of our working hours.

Support policy: Read the complete support policy which is part of our Terms of Service. We kindly remind our subscribers that they have already explicitly and unconditionally accepted the Terms of Service.