#11089 – Front end restores but can't access backend

Posted in ‘Kickstart / Backup Restoration’
This is a public ticket. Everybody will be able to see its contents. Do not include usernames, passwords or any other sensitive information.
Tuesday, 14 February 2012 05:55 CST
Mandatory information about my setup:

Have I read the related troubleshooter articles above before posting (which pages?)? Yes
Have I searched the tickets before posting? No
Have I read the documentation before posting (which pages?)?Some
Joomla! version: (2.5.1)
PHP version: (unknown)
MySQL version: (unknown)
Host: (optional, but it helps us help you)
Akeeba Backup version which took the backup: (3.3)
Kickstart version used to extract the backup: (3.3)

Description of my issue: I rebuilt a site on an unused domain then using backup restored it on my main domain. The front end looks fine but I get the following errot message when I try to login to the backend:

Fatal error: Call to a member function login() on a non-object in /home/XXX/public_html/mysite.com/administrator/components/com_login/admin.login.php on line 64
Edited by srglead2xl on 2012-02-14 11:55
Tuesday, 14 February 2012 06:12 CST
You tried to restore the Joomla! 2.5.1 site on top of an existing Joomla! 1.5, 1.6 or 1.7 site. You can not do that. Instead, remove ALL files and then restore your site.

Rule of thumb: if the version of Joomla! in your backup file is even a minor version different than the one installed on your site, you must wipe out your site before restoring it. Simply put: 1.5.x to 1.5.y: no need to wipe out the site. 1.5.x to 2.5.y: you must wipe out the site. 1.7.x to 1.7.y: no need to wipe out the site. 1.7.x to 2.5.y: you must wipe out the site.
Edited by nicholas on 2012-02-14 12:12

Tuesday, 14 February 2012 07:05 CST
Everything is great now. Thanks for your fast support, as usual - hope you saw my five star review:

"I've been using the free version of Akeeba Backup for a couple of years now and recently upgraded to the Pro version. It was absolutely worth every penny for the fabulous and fast support I got just when I needed it. Amazing value for money. Unmissable. The developer should get a medal"
Edited by srglead2xl on 2012-02-14 13:05
Tuesday, 14 February 2012 07:15 CST
You're welcome and thank you very much for your kind words!
Edited by nicholas on 2012-02-14 13:15

Tuesday, 14 February 2012 09:50 CST
I have now discovered a lot of little problems that I can't solve since doing a new restore of a joomla 2.5 site to a new domain.
1. In the backend, article manager, the accordian menus on the right stay open.
2. I can't insert an image into articles.
3. in Global Configurations, Permissions, none of the levels - admin, manager, etc, that I click on does anything.

Maybe there are other problems that I haven't discovered yet, but something must have gone wrong in the restore process. I did as you said, eliminated all the old joomla 1.5 files and even used a new database.

What would you suggest.

Edited by srglead2xl on 2012-02-14 15:50
Tuesday, 14 February 2012 09:54 CST
By the way, I didn't have any of these problems in the site that I backed up from, just in the one restored.
Edited by srglead2xl on 2012-02-14 15:54
Tuesday, 14 February 2012 10:01 CST
It may sound borderline silly, but have you tried clearing your browser's cache and cookies, then reload your site's back-end? I had the same problems when I restored this site (a Joomla! 2.5 site, the previous one being 1.5). After clearing my cache, it all worked.
Edited by nicholas on 2012-02-14 16:01

Tuesday, 14 February 2012 10:10 CST
That fixed it. Thanks!!! Sorry to waste your time with such trivia!!
Edited by srglead2xl on 2012-02-14 16:10
Tuesday, 14 February 2012 10:14 CST
You would be surprised how often I get this question. Every time someone upgrades an older site to 2.5.x or restores a 2.5.x site someplace an older Joomla! version used to live they have this issue. Browser caching has gotten more aggressive over the years. So did our CMS' reliance on JavaScript to operate. Putting the two together makes for an interesting conflict when upgrading Joomla! :)
Edited by nicholas on 2012-02-14 16:14

Tuesday, 14 February 2012 10:22 CST
Yes, it is weird. I have had bad response messages before and, at least 3 times, simply cleared my browser cache to fix it, but these errors seemed so isolated that I never dreamt it could be solved so easy, especially as I can still access the site I used to build and backup from and these issues weren't there in the same browser.

Anyway, thanks again!
Edited by srglead2xl on 2012-02-14 16:22
Tuesday, 14 February 2012 10:24 CST
Browser caching is persistent and only limited by time, hence the requirement to clear the cache :) You're welcome!
Edited by nicholas on 2012-02-14 16:24

This ticket is closed, therefore read-only. You can no longer reply to it. If you need to provide more information, please open a new ticket and mention this ticket's number.

Support Information

Working hours: Typically we work Monday to Friday, 9am to 7pm Cyprus timezone (EEST). Support is provided by the same developers writing the software, all of which live in Europe. We cannot respond to tickets outside of our working hours.

Support policy: Read the complete support policy which is part of our Terms of Service. We kindly remind our subscribers that they have already explicitly and unconditionally accepted the Terms of Service.