Support

Documentation

PHP errors , warnings, notices or a blank page upon accessing ANGIE / restoration

If you get a PHP fatal error, Internal Server 500 or a blank page you have to make sure that your server is indeed running on a supported version of PHP for the version of Akeeba Backup you are installing. Please consult our version compatibility matrix.

In order to determine which PHP version you're using, please create a file named info.php with the following contents:

<?php phpinfo(); ?>

Upload it to your server and access it as http://www.yoursite.com/info.php, where www.yoursite.com is your web site's domain name. You will see your PHP version on top. If the PHP version is unsupported please ask your host to immediately upgrade your PHP. Do not ask us for such instructions. This is absolutely server-specific and we can't possibly help you.

If, however, you are getting PHP Warning, Notice, Strict Standards or Deperecated messages, this is nothing to worry about, meaning that ABI will work properly but its interface might be so loitered with the messages that it's impossible to use. In that case please ask your host about instructions on either disabling PHP error output to the browser or setting the error reporting level to E_ERROR. If you are on a local server (e.g. XAMPP, MAMP, WAMPServer, etc) you have to edit your php.ini file and change the following two lines:

error_reporting = E_ERROR
display_errors = 0

If you don't know where your php.ini file is stored, please consult the documentation or support forum of your server stack (e.g. XAMPP) you are using. We know about a few of them, but not all of them. It's best to ask such questions on the official site of each server stack where you can get proper support about those non-Akeeba products.

[Important]Important

You MUST restart Apache (the web server service) after applying those changes. If you are unsure about how to do that, you'd better shut down and restart the server stack (e.g. XAMPP) you are using.