Support

Documentation

Common issues on restored sites due to PHP incompatibilities between the source and target server

PHP version incompatibilities

You have to consider the PHP version of the original and new server. If your original server was running on a newer version of PHP than the new server, you might end up with a blank page. This is especially true if your new host is running a different PHP version family (5.5 vs 5.4 for example) or has disabled some critical PHP functions. This is not a restoration problem, rather than a hosting configuration error. Some modules, components or plugins you have installed might be using functions which are not available on your new host. The only way to understand if this is the case is to have your host take a look at the error log and reconfigure your hosting environment to fix this issues.

If you are restoring to a local server, you might have one version of PHP which is too new or too old for Joomla! to work with. Please consult Joomla.org for PHP version compatibility information.

PHP memory issues

If you are restoring to a local server, please make sure that your PHP memory limit is adequately high. On some local hosts the default setting is 8Mb, which is too low for Joomla!. You can determine this be editing your local server's php.ini file. Look for this line:

memory_limit = 8M

Change it so that it reads:

memory_limit = 64M

If you are on a live host, please ask your host and make sure that your PHP memory limit is at least 32M. If it's not, ask your host for the proper way to increase it.

Error reporting matters

Finally, some people see PHP errors (Deprecated, Notice, Warning) when accessing their website which most of the times this is not a problem with the restoration but an issue with the server configuration. In most cases you can simply set Error Reporting to None in Joomla!'s Global Configuration page. If this doesn't work, please ask your host for information on disabling PHP's error output to the browser. Anyway, it's a good idea to do so in the first place! You don't want any minor glitch to reveal sensitive server configuration information to potential hackers.

If you are your own host, e.g. using a local installation of WAMPserver, XAMPP, MAMP, etc., the easiest way to do that is by editing your php.ini file and setting error_reporting = E_ERROR. Remember to restart Apache for the change to have any effect at all!